4k-5k RPM hesitation

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

Re: 4k-5k RPM hesitation

Postby 88gt4DE » Tue Feb 01, 2011 7:21 pm

Mine too and had rusty gas tank clogging filter ... 2nd Mafix recommendation. pain in the ass to hook up but fuel pressure tester and tape it to the glass and watch reading in trouble zone .... mine dropped to almost 15 psi when it got really bad .... should be up in the 30's range ...
Members don't see the above ad. Register now - it's free!
Rob
1988 ST165 - 77K - Project ---> http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=31483&start=240
2000 Toyota Tundra SR5 - 162K - DD - Thanks 97JZA80
2007 Toyota Rav4 - 110K - My girls DD
1999 Honda Civic - 116K - Highway Runner
User avatar
88gt4DE
Established Member
 
Posts: 2665
Joined: Tue Nov 25, 2008 2:44 am
Location: New Castle , DE

Re: 4k-5k RPM hesitation

Postby gpmarzan » Tue Feb 01, 2011 11:35 pm

bloodMoney wrote:I've got a generic FPR if you want it Patrick. I can't remember if it has a gauge on it, but if you want it, let me know.

Dude its worth a shot, pass it on over here if you have it. :D

btw, I love coming on this forum and seeing my sig. The st165 just look so damn good.
Patrick M.
st165

Image
User avatar
gpmarzan
Established Member
 
Posts: 1537
Joined: Mon Sep 06, 2004 9:28 pm
Location: Greenwood, IN

Re: 4k-5k RPM hesitation

Postby bloodMoney » Wed Feb 02, 2011 12:16 am

Its up at the barn in MI, so the next time I'm up there, I'll get it for you.
88 ST165 'Patty'
90 ST185 'Ellie'
'96 GT "Abby" ~ RIP 11/17/2013
'96 GT 'vert "Lily" ~ RIP 08/22/2015
'04 LS430 "Alice"
'98 GS400
User avatar
bloodMoney
Gold Member
 
Posts: 1185
Joined: Tue Jan 25, 2005 8:30 am
Location: Chicagoland

Re: 4k-5k RPM hesitation

Postby gpmarzan » Sat Feb 05, 2011 2:53 pm

Acquired another oem regulator from someone on mr2oc forum. Waiting for that to come in to try it out.
Its getting really annoying. In 2nd gear even at 8-9 psi, if I step on it anywhere below WOT it hauls pretty good. If I do the same at WOT in the same gear, you feel the car not pull as hard, specially at around 4k RPM where you really feel it pull back. Still no codes.
Patrick M.
st165

Image
User avatar
gpmarzan
Established Member
 
Posts: 1537
Joined: Mon Sep 06, 2004 9:28 pm
Location: Greenwood, IN

Re: 4k-5k RPM hesitation

Postby timco » Sat Feb 05, 2011 10:00 pm

I'm having this same issue, have an 88 all trac with an st205 3sgte swapped in, havent had time to check into yet as Im replacing all the struts/shocks/rotors(bla bla) I'll be looking more in depth when I get a chance though. Running only 8 psi atm.
kris
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: 4k-5k RPM hesitation

Postby gpmarzan » Sun Feb 06, 2011 7:49 pm

I figure its running really, really rich or lean at WOT. I really need to get a new downpipe and hook up my wideband.
Patrick M.
st165

Image
User avatar
gpmarzan
Established Member
 
Posts: 1537
Joined: Mon Sep 06, 2004 9:28 pm
Location: Greenwood, IN

Re: 4k-5k RPM hesitation

Postby gpmarzan » Fri Feb 18, 2011 1:37 am

small update:

So I replaced the FPR as Mafix stated which, btw, was a pain in the ass. Did a few WOT pulls in 2nd gear and the problem seem to have gone away! Pull strong now at 4 thru 6, but im still not convinced though. Need to do a few more runs to really confirm if its fixed. 8)
Patrick M.
st165

Image
User avatar
gpmarzan
Established Member
 
Posts: 1537
Joined: Mon Sep 06, 2004 9:28 pm
Location: Greenwood, IN

Re: 4k-5k RPM hesitation

Postby Grey_Matter » Fri Feb 18, 2011 10:39 pm

gpmarzan wrote:small update:

So I replaced the FPR as Mafix stated which, btw, was a pain in the ass. Did a few WOT pulls in 2nd gear and the problem seem to have gone away! Pull strong now at 4 thru 6, but im still not convinced though. Need to do a few more runs to really confirm if its fixed. 8)



makes me want to change mine out for shits and giggles...cause i know this car should at the minimum take off faster than my jetta...but my jetta blows its doors off
Grey_Matter
Club Member
 
Posts: 91
Joined: Mon Dec 06, 2010 1:10 pm

Re: 4k-5k RPM hesitation

Postby gpmarzan » Mon Feb 21, 2011 9:15 pm

gpmarzan wrote:small update:

So I replaced the FPR as Mafix stated which, btw, was a pain in the ass. Did a few WOT pulls in 2nd gear and the problem seem to have gone away! Pull strong now at 4 thru 6, but im still not convinced though. Need to do a few more runs to really confirm if its fixed. 8)

I spoke too soon. The problem still persist. The power delivery is very inconsistent. Most of the time, power is good anywhere below WOT at any boost, but sometimes its not. Most of the time at WOT it pulls back at high RPM, but it sometimes does at low rpm. Again, very inconsistent. The time when I thought it was fix was when the battery was just connected so im assuming once the ecu learned all the conditions is when it started acting up. I dont know. Maybe my fuel pump is going? AFM? or ECU? Those are basically the only 3 that I have left to mess with (aside from rechecking static timing)
Patrick M.
st165

Image
User avatar
gpmarzan
Established Member
 
Posts: 1537
Joined: Mon Sep 06, 2004 9:28 pm
Location: Greenwood, IN

Re: 4k-5k RPM hesitation

Postby Rallly » Sat Aug 22, 2015 6:41 pm

gpmarzan wrote:
gpmarzan wrote:small update:

So I replaced the FPR as Mafix stated which, btw, was a pain in the ass. Did a few WOT pulls in 2nd gear and the problem seem to have gone away! Pull strong now at 4 thru 6, but im still not convinced though. Need to do a few more runs to really confirm if its fixed. 8)

I spoke too soon. The problem still persist. The power delivery is very inconsistent. Most of the time, power is good anywhere below WOT at any boost, but sometimes its not. Most of the time at WOT it pulls back at high RPM, but it sometimes does at low rpm. Again, very inconsistent. The time when I thought it was fix was when the battery was just connected so im assuming once the ecu learned all the conditions is when it started acting up. I dont know. Maybe my fuel pump is going? AFM? or ECU? Those are basically the only 3 that I have left to mess with (aside from rechecking static timing)



Did you figure this out?
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Previous

Return to General Maintenance and Repair

Who is online

Users browsing this forum: No registered users and 2 guests