Electrical gremlins, engine retards when wet

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

Electrical gremlins, engine retards when wet

Postby Killtodie » Wed Nov 18, 2015 4:40 pm

This has been happening most of the time. Whenever I drive over some large puddles (I dont have any undergaurds) my engine starts to retard the timing, and I cant get into boost. This lasts for a bit, and then goes away.

I first started noticing this when I was rinsing off an oil leak around the filter housing so I could trace it better. Everytime I washed the exhaust side of the engine, nor mater how careful I was, immediately after the car would bog down, and run like ass.

My question is, what could possible get wet there for this to happen?
I thought maybe the knock sensor, but its on under the intake side. Its possible that it gets wet from driving under a puddle, but not when I use low pressure water to rinse the exhaust side of the block.

I avoid getting any of the connectors wet, but I do hose off the water neck liberally. Anything there could cause this? I have EGR delete, I still have the BVSV in there, and anything else is just a sensor. Would anything there cause my issue?
Members don't see the above ad. Register now - it's free!
1988 Chrysler Conquest
As seen on YouTube https://www.youtube.com/watch?v=YIY4wuwc8XA
1988 Toyota Celica All-Trac
Killtodie
Club Member
 
Posts: 585
Joined: Tue Jul 31, 2012 4:57 pm

Re: Electrical gremlins, engine retards when wet

Postby 88gt4DE » Sun Nov 22, 2015 12:43 pm

Strange ... no CEL when this happens ?
Rob
1988 ST165 - 77K - Project ---> http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=31483&start=240
2000 Toyota Tundra SR5 - 162K - DD - Thanks 97JZA80
2007 Toyota Rav4 - 110K - My girls DD
1999 Honda Civic - 116K - Highway Runner
User avatar
88gt4DE
Established Member
 
Posts: 2665
Joined: Tue Nov 25, 2008 2:44 am
Location: New Castle , DE

Re: Electrical gremlins, engine retards when wet

Postby Killtodie » Sun Nov 22, 2015 4:50 pm

88gt4DE wrote:Strange ... no CEL when this happens ?


No.

Some of the wiring is old, tape peeled off, connection ends exposed, so I know something is shorting out, just trying to figure out what could cause the engine to retard timing, like its going in limp mode.

O2 sensor? Knock sensor? only two I can think off.
1988 Chrysler Conquest
As seen on YouTube https://www.youtube.com/watch?v=YIY4wuwc8XA
1988 Toyota Celica All-Trac
Killtodie
Club Member
 
Posts: 585
Joined: Tue Jul 31, 2012 4:57 pm

Re: Electrical gremlins, engine retards when wet

Postby Bempa » Sun Nov 22, 2015 4:54 pm

Have you checked is there is any stored fault codes?
AE92 4age 20v Engine rebuilding
KE70 4age 16v In progress
ST165 3sgte Brum Brum
ADT251 2ad-fhv Daily
AE92 4age 16v Bigport What to do with this one?
ACM20 1az-fe Wife´s daily


Instagram Benny_Gustavson
Bempa
Club Member
 
Posts: 62
Joined: Wed Jul 16, 2014 1:47 pm

Re: Electrical gremlins, engine retards when wet

Postby Killtodie » Sun Nov 22, 2015 5:04 pm

Bempa wrote:Have you checked is there is any stored fault codes?


No, same way to read normal codes?
1988 Chrysler Conquest
As seen on YouTube https://www.youtube.com/watch?v=YIY4wuwc8XA
1988 Toyota Celica All-Trac
Killtodie
Club Member
 
Posts: 585
Joined: Tue Jul 31, 2012 4:57 pm

Re: Electrical gremlins, engine retards when wet

Postby Bempa » Sun Nov 22, 2015 5:07 pm

Yes it's the same way
AE92 4age 20v Engine rebuilding
KE70 4age 16v In progress
ST165 3sgte Brum Brum
ADT251 2ad-fhv Daily
AE92 4age 16v Bigport What to do with this one?
ACM20 1az-fe Wife´s daily


Instagram Benny_Gustavson
Bempa
Club Member
 
Posts: 62
Joined: Wed Jul 16, 2014 1:47 pm


Return to General Maintenance and Repair

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests