What did I blow? Hooked up jumper cables backwards

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

What did I blow? Hooked up jumper cables backwards

Postby maxaud » Sat Feb 04, 2017 12:01 am

I hate making a post like this. My GT-four has been sitting for a little while and needed a jump to get started.

The person who hooked up the jumper cables hooked them up backwards and some smoke started coming off of the positive battery lead. I took it off the battery posts but the car rather promptly but it doesn't have any power now.

Figured I'd come in from the cold and see if anyone here knows what to look for when something like this has happened?

Thanks!
Members don't see the above ad. Register now - it's free!
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: What did I blow? Hooked up jumper cables backwards

Postby Nobody » Sat Feb 04, 2017 1:34 am

Probably just a fuse. Check the fuse box under the hood. I had a bad alternator in my car that kept internally grounding and popping a fuse. Replaced the alt and fuse, no more problem.
Nobody
Club Member
 
Posts: 27
Joined: Fri May 18, 2012 1:43 am

Re: What did I blow? Hooked up jumper cables backwards

Postby mx6er2587 » Sat Feb 04, 2017 2:33 am

Typically it's the 100 amp fuse in the main fuse box that blows in this situation. Careful this is a Bolt in fuse. I've seen these things mangled by trying to just pull them straight out
mx6er2587
Established Member
 
Posts: 1162
Joined: Sun Jan 27, 2008 12:08 am
Location: Pittsburgh PA

Re: What did I blow? Hooked up jumper cables backwards

Postby audiodjmp77 » Sat Feb 04, 2017 11:09 am

Sounds like what happened to me, but I ended up stripping the dash to check out my other wiring, which looks OK, so time to put it back together

Sent from my phone. Sorry for any mistakes
audiodjmp77
Club Member
 
Posts: 34
Joined: Wed Oct 02, 2013 5:02 pm

1990 Toyota Celica

Re: What did I blow? Hooked up jumper cables backwards

Postby maxaud » Sun Feb 05, 2017 12:47 am

Thanks guys. 100amp fuse was definitely gone. Started right up with that replaced. Still having this problem though even after 4 years: viewtopic.php?f=10&t=47431
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: What did I blow? Hooked up jumper cables backwards

Postby Rick89GTS » Sun Feb 26, 2017 3:17 am

mx6er2587 wrote:Typically it's the 100 amp fuse in the main fuse box that blows in this situation. Careful this is a Bolt in fuse. I've seen these things mangled by trying to just pull them straight out

Excellent point.
User avatar
Rick89GTS
GTFour God
 
Posts: 3747
Joined: Sun Aug 08, 2004 6:28 am
Location: Great White North, Canada


Return to General Maintenance and Repair

Who is online

Users browsing this forum: Bing [Bot] and 2 guests