Bad distributor?

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

Bad distributor?

Postby lalojamesliz1 » Sat Jan 27, 2018 4:25 am

Earlier today I had a code 12 on my gen3. Everything is plugged in but I have a low idle problem. When I let off the throttle my rpms drop to like 600 and when I come to a stop it climbs to 1000. Drives and boots fine.
Can a autopart store replacement dizzy work on my gen3?
Earlier today after I cleared the the code 12 thing I was cruising around and did a 15 psi pull and tool out knock sensor #3 :shoots: :shoots: :shoots:
I love this car and want it for a daily but...... I can't sell it
Members don't see the above ad. Register now - it's free!
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 199
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA

Re: Bad distributor?

Postby lalojamesliz1 » Sat Jan 27, 2018 4:43 am

When I took out the knk sensor I got home and reset the ecu then when for a drive and the light didn't come back on. Right now I backed out of my driveway to go to work the light cel came on...... man! I don't understand why I keep taking out the knk sensors. I never had this problem when I previously had it and it was a gen2 with gen3 efi. I boosted 17 all the time too
I'm using a st205 ecu with the code54 fix
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 199
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA

Re: Bad distributor?

Postby lalojamesliz1 » Sun Jan 28, 2018 8:06 pm

Damn :|
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 199
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA


Return to General Maintenance and Repair

Who is online

Users browsing this forum: No registered users and 1 guest