I need help Please

Talk about the other Celica models

I need help Please

Postby patchat88 » Fri Dec 28, 2007 11:49 pm

Hi, I have done a 3sgte swap in my 90 celica. and now he start perfectly, idle OK but when I hit the gas too fast hey seem to missfire at 4000 rpm and when i slowly push on the gas i can take it to 5500 rpm but I have all ignition compenent new and i think am not suposed to have the rev limiter at 5500 so if some one can help i will be the happiest guy on earth lol
Members don't see the above ad. Register now - it's free!
patchat88
Club Member
 
Posts: 47
Joined: Tue Oct 23, 2007 4:05 am

Postby RedCelicaTRD » Sat Dec 29, 2007 12:03 am

Did you replace the stock fuel pump?
Wayne
1990 All Trac
2017 SRT Challenger Hellcat
Grumpy Moderator
RedCelicaTRD
GTFour God
 
Posts: 3947
Joined: Sun Aug 08, 2004 6:58 pm
Location: Syracuse, UT

Postby patchat88 » Sat Dec 29, 2007 2:48 am

yea I have a walbro 255lph
do you think it can be a clogged fuel filter or injector ??
patchat88
Club Member
 
Posts: 47
Joined: Tue Oct 23, 2007 4:05 am

Postby RedCelicaTRD » Sun Dec 30, 2007 3:47 am

A clogged fuel filter is possible. And even if your fuel pump is new, don't rule it out. I know that Walbro had a couple batches of crappy pumps a few years ago.
Wayne
1990 All Trac
2017 SRT Challenger Hellcat
Grumpy Moderator
RedCelicaTRD
GTFour God
 
Posts: 3947
Joined: Sun Aug 08, 2004 6:58 pm
Location: Syracuse, UT

Postby syko says » Sun Dec 30, 2007 5:34 am

Any CELs?
Aloha,
Evan

RedCelicaTRD wrote:I've got my eye on you wise guy :|
User avatar
syko says
Established Member
 
Posts: 2307
Joined: Thu Mar 23, 2006 5:27 pm
Location: Waipahu, Hawaii

Postby patchat88 » Sun Dec 30, 2007 7:02 pm

no cells and on my wideband when he missfire i have 10.1 ratio so am not lean am rich so I have gaz
and its normal at idle i have 11.1 its normal ??
patchat88
Club Member
 
Posts: 47
Joined: Tue Oct 23, 2007 4:05 am

Postby patchat88 » Mon Dec 31, 2007 4:52 pm

bump
patchat88
Club Member
 
Posts: 47
Joined: Tue Oct 23, 2007 4:05 am

Postby Mafix » Mon Dec 31, 2007 7:01 pm

sounds like it's time to test the AFM.
Mafix
Gold Member
 
Posts: 5877
Joined: Tue Aug 10, 2004 10:56 pm

Postby Corey » Mon Dec 31, 2007 7:05 pm

^^ plus 1

are the plugs gapped correctly?
Image
User avatar
Corey
GTFour God
 
Posts: 4123
Images: 50
Joined: Sun Feb 11, 2007 12:12 am

1989 Toyota Celica

Postby hacker_720 » Tue Jan 01, 2008 1:22 am

here's a simple one to put on your list:

all grounds ok?
BOTTLE ARE FOR BABIES...REAL MEN GET BLOWN
1990 ST185 2.2Lt
hacker_720
Established Member
 
Posts: 1634
Joined: Tue Jun 14, 2005 12:32 pm
Location: Toronto, Ontario, Canada

Postby patchat88 » Tue Jan 01, 2008 10:15 am

I have clean my afm and tested and they are on the spec of the bgb I will try it tomorow and my plug are brand new cooper gapped at 0.028 and for the ground i have check to the ecu and i have ground on all specified place so am really confuse
patchat88
Club Member
 
Posts: 47
Joined: Tue Oct 23, 2007 4:05 am


Return to FWD Celica

Who is online

Users browsing this forum: No registered users and 1 guest