Page 5 of 5

Re: 185 A/C issues on 205 swap

PostPosted: Tue Feb 04, 2014 7:47 pm
by CMS-GT4
I was going through some old notes today, and I found something from Scott that might be helpful. My system isn't charged, plus its single digits here so I can not test at the moment.

The A/C temp switch that the 185 had in the water neck is not available on the 205 neck.
So there were two options noted there for making the AC work.
1) tapping the water neck and adding the 185 sensor, which retains the safety system if you over heat.
2) Close the switch for this wire.
It is normally closed and opens if the engine is over heating. So if you ground it, you remove the saftey feature but it should allow the AC to turn on.

If anyone wants to try it, keep us posted. If not, I will see if I can trip my pressure switch and try it when its warm.

Re: 185 A/C issues on 205 swap

PostPosted: Wed Feb 05, 2014 4:34 pm
by phattyduck
Interesting thought. I have the CF pin (cooling fan?) pin hooked up on my 205 swap (hooks to the trigger side of the cooling fan relay, couldn't tell if it was an input or output of the ECU). I thought it might also be able to turn on the fans if the air intake temp gets too high.

I have a switch in the cabin that interrupts that same signal for radiator water temp switch. I haven't noticed my AC not working when I have the fans turned on manually. I'm using the ST205 radiator so I have a 2-pin water temp switch at the bottom of the radiator that I use - no need to weld something on the water inlet neck. The in-cabin switch is in series with the factory temps switch and is also the AC high-pressure switch that makes the fans go in parallel instead of series for normal AC operation. I suppose I could check how it operates in that mode - but I also have the stock AC electronics doing everything except controlling the idle-up, so it isn't 100% ST205 style...

-Charlie

Re: 185 A/C issues on 205 swap

PostPosted: Wed Feb 05, 2014 6:47 pm
by alltracman78
That temp switch in the 185 coolant neck is ONLY pre revision cars. US and JDM.
Post revision cars don't have that sensor at all IIRC. Or if they do it's in the heater core. I don't have any paperwork with me to double check.

Re: 185 A/C issues on 205 swap

PostPosted: Sat Apr 05, 2014 1:37 am
by soarer.jzz30
I posted about this in the wrong thread

Re: 185 A/C issues on 205 swap

PostPosted: Thu Apr 10, 2014 5:41 am
by soarer.jzz30
Duck gave me an idea, it may be a different temperature that the radiator fan switch turns the fan on, but perhaps the tie into that switch to complete the condensor fan circuit? Just a thought.

Re: 185 A/C issues on 205 swap

PostPosted: Mon May 19, 2014 9:03 am
by soarer.jzz30
totally just burned up my oem compressor by manually kicking on the clutch, compressor was seized because it sat to long and had water and rust in it. Then the clutch wouldn't disengage because it also was rusted from sitting... So the belt melted and snapped in a very short period of time. I'll be installing lots of new parts and be tackling it once again after.

Re: 185 A/C issues on 205 swap

PostPosted: Wed Sep 10, 2014 2:39 am
by CMS-GT4
I have a new dryer installed, and another compressor. Now I am just hunting for the wire for the ac water temp on the harness, but I have not been able to find it. I think if I can find it at the amplifier, I might be able to ground it to resolve the AC.

Re: 185 A/C issues on 205 swap

PostPosted: Wed Sep 10, 2014 7:06 pm
by CMS-GT4
Here is the diagram of the amp and water temp. If I can not find it in the engine bay, perhaps I can go after it by the amp. It looks like it connects to the thermistor, so that might be where to start.

Re: 185 A/C issues on 205 swap

PostPosted: Tue Apr 25, 2017 1:30 am
by CMS-GT4
Once I'm done with finals next week I am jumping into this. My first attempt will be to find the ac water temp sensor. I can't find the plug so I will try and locate at the amp.
Next will be ac idle up. The 205 ecu controls it so I will try and reroute the amp wire to the ecu and see what happens. I need to read more into these diagrams before I attempt anything.
I currently have ac but the lack of idle up causes problems.

Re: 185 A/C issues on 205 swap

PostPosted: Wed Aug 16, 2017 12:23 am
by CMS-GT4
Been doing some research, and here are my notes so far. This will be updated as I get further along.

There are different wiring setups for various st185. I am sure euro and jdm have their own issues, but as far as North American models we have at least two setups. 90-91 vs 92-93. 93 has some ac differences from 92, but afaik the wiring is about the same. Auto AC is different from dial AC. I know some foreign models are without auto. Since I have auto, my research is focused there.

Info is spread out across the bgb 1 & 2 as well as the electrical supplement. All are really needed for the full picture. I also have some other digital BGBs that have a whole slew of other info not in the official BGB, though most of it not relevant. The 92 bgb has a misprint. It has a detail on there being a 3rd water temp sensor but that seems to actually be for the 90-91 models. So that means it has two. There is one linked to the pressure switch that goes to the temp sensor in the rad. The next is under the dash and works with the amp.

So to start with my car is a 92 US model. The engine is a late model st205 with 205 ecu using a modified 185 harness. Setting the swap up completely the ac will not activate. When you remove the ACT wire from the ECU the ac will turn on. This is the state I have run it in since the swap. Even though the AC works, here is why I want to resolve this project.
The car runs great with no ac. Idles well, and drives well. Once you have activated the AC idle is not great, but it does idle fine with the AC on. The issue is low rpm driving (parking the car) tends to bog down some and run too low on the rpm. The other rpm issue is once you turn off the AC the car will idle so low it will sometimes die. The last flaw is the AC only produces fully cold. It does not register any other temps. Its either ice cold or no AC.

I think these issues tie to a couple of components on the st205 setup. The idle problem seems easy to explain. In the 185 the ac amp controls the idle up VSV. For the 205 the ECU controls this function. So what is happening when you turn on the AC the system is not bumping up the idle. My guess is once you turn off the AC the ecu lowers the idle based off of where it was while the AC was on. I think the easiest way to resolve this is simply move the idle up function from the ac amp to the ECU. I want to confirm voltage, but I think this will resolve it. Another method that I had read about from a 6th gen running a 185 engine is they hooked the idle up vsv to the AC compressor. So it only turned on when the AC was active. The 205 may have a more involved way of controlling it vsv on and off, so I think the ECU hook up is the best route.

Now for the ACT issue. I am unsure. I need to dig deeper in the BGBs but it looks like there is continuity based on engine water temp, which lead me to think the 3rd water temp sensor existed on my car. This could be a typo on toyota's part. I think the only issue that this causes is possibly the lack of ac temp modulation, but I can not be sure. I can live with that flaw if I can deal with the idle up. Frankly that is the only problem that seems to affect the drivability of the car, which can be restored by resetting the ecu after turning the AC off.

As I figure out more and come up with my solutions, I will report back.

Re: 185 A/C issues on 205 swap

PostPosted: Sat Aug 19, 2017 12:40 am
by CMS-GT4
Update. I have been digging through 205 and 185 bgbs and found the ac idle up vsv has the same voltage specs as the one from a 5sfe 18x. On that note, I tried to jump the valve with no results. I need to check its resistance, but it may be faulty. If that is the case, then I will adjust for my next steps.