Power but no sound from radio

For everything related to the inside of the car!!

Re: Power but no sound from radio

Postby lumbercis » Tue May 10, 2011 12:09 am

Just to update this thread, I took the car to a local car audio place and the guy there said he thought the head unit was bad... One thing I neglected to test was playing CDs. It actually will play CDs but very softly. You have to crank the volume almost all the way up to get much sound. Didn't really check each speaker in detail, but he said he didn't think it was likely a wiring issue or an issue with the antenna, and since I'd already tried another amp...

This is thread on MR2Oc I mentioned before: http://www.mr2oc.com/showthread.php?t=240774

It looks like our cars use the 15-pin connectors. Anyone know what other Toyota head units use that connector?

Thanks
J.
Members don't see the above ad. Register now - it's free!
Caldina powered...
Image
lumbercis
Gold Member
 
Posts: 2346
Joined: Fri May 13, 2005 4:52 am
Location: Washington, D.C.

Re: Power but no sound from radio

Postby Brad_91 » Tue May 10, 2011 3:02 am

lumbercis wrote:Just to update this thread, I took the car to a local car audio place and the guy there said he thought the head unit was bad... One thing I neglected to test was playing CDs. It actually will play CDs but very softly. You have to crank the volume almost all the way up to get much sound. Didn't really check each speaker in detail, but he said he didn't think it was likely a wiring issue or an issue with the antenna, and since I'd already tried another amp...
J.


Was he able to repair it or did you just get a new one?? If it is an easy fix I would get it repaired..
Brad
1992 Celica GT-Four
~65'000km,
Mods: Turbo-back 3" Exhaust, 17x8 Versus Turismo Rims, Black Rally Armor Mud Flaps, turbo timer, manual boost controller, Whiteline rear swaybar!
User avatar
Brad_91
Club Member
 
Posts: 393
Images: 0
Joined: Tue Dec 14, 2010 4:23 pm
Location: Ontario, Canada

1992 Toyota Celica

Re: Power but no sound from radio

Postby lumbercis » Tue May 10, 2011 3:26 am

I'm looking for a replacement... he didn't seem inclined to want to repair a stock system.. probably not much money in it for him.

J.
Caldina powered...
Image
lumbercis
Gold Member
 
Posts: 2346
Joined: Fri May 13, 2005 4:52 am
Location: Washington, D.C.

Re: Power but no sound from radio

Postby Brad_91 » Tue May 10, 2011 1:55 pm

Alright thanks! I guess I'll be looking for one too..

Brad
Brad
1992 Celica GT-Four
~65'000km,
Mods: Turbo-back 3" Exhaust, 17x8 Versus Turismo Rims, Black Rally Armor Mud Flaps, turbo timer, manual boost controller, Whiteline rear swaybar!
User avatar
Brad_91
Club Member
 
Posts: 393
Images: 0
Joined: Tue Dec 14, 2010 4:23 pm
Location: Ontario, Canada

1992 Toyota Celica

Re: Power but no sound from radio

Postby BoostedBlueToyotas » Wed May 11, 2011 12:17 am

The low volume from CD player is a known problem. There are some bad capacitors on the boards in the radio. There was a writeup on which ones, locations and sizes at one point on the board. Dont know if it exists anymore. I just took mine in to an audio repair place and shelled out 300 to have mine fixed (several years ago)
Tim Plessing
Columbia, MD

1990 ST185 - blue/blue cloth 152K-SOLD
1993 MR2 turbo - blue/black leather 59K TOTALLED/PARTING OUT
2006 Acura TSX - black/black 6 spd
2006 Mini Cooper S JCW Space blue/Silver roof 39k
2006 Mini Cooper JCW Silver/black roof 34k
BoostedBlueToyotas
Established Member
 
Posts: 2663
Joined: Mon Aug 09, 2004 11:33 pm
Location: Columbia, MD

Re: Power but no sound from radio

Postby lumbercis » Wed May 11, 2011 1:08 am

Ahh, yeah, I did see mention of that in another thread although it mentioned to do the fix yourself would involve soldering new capacitors on the board yourself (or taking it to a shop as you did).

Certainly be interesting to see what a shop would charge nowadays. Not sure if it would be more than you could get a used 15-pin type replacement for such as this:

http://cgi.ebay.com/ebaymotors/Toyota-C ... ioQ5fVideo

I thought $175 was a bit expensive, but maybe not a bad deal considering what repairing the stocker might cost?

A cheaper option is something like this:
http://cgi.ebay.com/ebaymotors/ws/eBayI ... K:MEWAX:IT
Although the pins aren't clearly visible, I'm almost certain this is the 15-pin plug. Kinda cool single-din option from a 6th gen celica.
Caldina powered...
Image
lumbercis
Gold Member
 
Posts: 2346
Joined: Fri May 13, 2005 4:52 am
Location: Washington, D.C.

Re: Power but no sound from radio

Postby Brad_91 » Wed May 11, 2011 2:58 am

Does anyone know if the head-unit from the st205 works? It did not have the system ten like my car...
Brad
1992 Celica GT-Four
~65'000km,
Mods: Turbo-back 3" Exhaust, 17x8 Versus Turismo Rims, Black Rally Armor Mud Flaps, turbo timer, manual boost controller, Whiteline rear swaybar!
User avatar
Brad_91
Club Member
 
Posts: 393
Images: 0
Joined: Tue Dec 14, 2010 4:23 pm
Location: Ontario, Canada

1992 Toyota Celica

Re: Power but no sound from radio

Postby underscore » Wed May 11, 2011 3:47 am

$300 to replace some caps? geez that seem steep. If you're decently handy with tools and small pieces I don't see why DIY would be too hard, as capacitors are very easy to replace.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3792
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Previous

Return to Audio / Wiring / Interior

Who is online

Users browsing this forum: No registered users and 3 guests