can someone help me out with my mechman alt install

For everything related to the inside of the car!!

can someone help me out with my mechman alt install

Postby lalojamesliz » Fri Mar 09, 2012 6:54 pm

I have a new situation and was wondering if someone can help me out. I just bought a mechman 150 amp alternator for my all-trac. I just ordered it yesterday but I need to prepare for the install. I already bought a new belt for it and I already have "the big 3 upgrade" done to my all-trac with monster cable oxygen free 1 guage cable with a 200amp fuse right next to my red top optima battery that's relocated to the rear. The thing I'm questioning is I called mechman to ask them about installing it and they said I should run 0 guage positive and negative hot cables to my battery to make sure it gets all of the power of the alternator but do I really need those cables? I told the guy what I already have done and he told me they recommend those cables to everyone and its at my discretion if I use them. I really don't want to run 0 guage cables to my battery because just running the 1 guage positive cable through my frame/body of my car was a huge PITA. I have all of my positive connections on the main + of the starter including the 1 guage from my battery and I was thinking of just running a copper 4 guage from the positive of the alt to the + of my starter with all of the other connections and ground the negative of the alt to the body inside the engine bay with the same 4 guage copper cable. From what I understand the alternator has external connections for these extra cables. What do you guys think?
Members don't see the above ad. Register now - it's free!
User avatar
lalojamesliz
Club Member
 
Posts: 222
Images: 0
Joined: Sat Jan 03, 2009 8:14 am
Location: Bakersfield,CA

Re: can someone help me out with my mechman alt install

Postby c 45 » Sat Mar 10, 2012 2:09 am

:D honestly mechman knows alot hes a good guy i deal with alot of competition car audio stuff and i too recomend running 0awg from the alt back in ur case i understand where your comming from but if you have the big three done with 1awg than ur cables comming from the alt now should be 1awg correct if not than you didnt do the big three so you should make sure you have the 1awg running from the alt to the battery this alt really needs it also will help with not overheating the alt
Colt 45
sacramento
1988 alltrac
c 45
Club Member
 
Posts: 44
Joined: Mon Mar 05, 2012 9:23 pm
Location: sacramento

Re: can someone help me out with my mechman alt install

Postby lalojamesliz » Sat Mar 10, 2012 4:53 am

i had a 4guage from the alt to the battery location but i removed it because the wire loom i had over it began to melt from the engine heat. what do you think of this... my 1 guage power wire comes out from the passenger fender then runs along the firewall up to the brake booster then goes to the starter and everything hooks up to that. instead of running the extra power wire around the engine over the heat, ill just put a 3-way 1 guage on the passenger fender where the main cable comes out. if i was pushing big amperage 220+ then i would agree with running more cables
User avatar
lalojamesliz
Club Member
 
Posts: 222
Images: 0
Joined: Sat Jan 03, 2009 8:14 am
Location: Bakersfield,CA

Re: can someone help me out with my mechman alt install

Postby c 45 » Sat Mar 10, 2012 9:11 am

where in cali are you located ? id like to see what you have in mind are ur alt wires the stocks now ? cause thats not a big three you got ?
Colt 45
sacramento
1988 alltrac
c 45
Club Member
 
Posts: 44
Joined: Mon Mar 05, 2012 9:23 pm
Location: sacramento

Re: can someone help me out with my mechman alt install

Postby lalojamesliz » Sat Mar 10, 2012 6:41 pm

im in bakersfield 275 miles away from you. as of right now i dont have a bigger cable going from the alternator to the battery wire because i got worried about the heat meting the extra 4 guage wire i had on it. as it sits i have a 1/0 cable going from my battery (cargo area) to my starter, a 1/0 cable from my starter mounting bolt to the chassis, a 4 guage from the trans to the chassis, i replaced the fuse box main power wire that went to the battery with a 4 guage so that goes from the fuse box to the starter + and a 1/0 cable from my negative battery terminal to the chassis. that should give you a good idea of my system. when i did have the extra power wire from my alt to the battery my lights still dimmed so it didnt bother me taking it off when i had the heat issue with the wire loom. i have hid's now (real ones not from ebay) so my lights dont dim but my dash lights and heater/ac fan slows at low engine rpm
User avatar
lalojamesliz
Club Member
 
Posts: 222
Images: 0
Joined: Sat Jan 03, 2009 8:14 am
Location: Bakersfield,CA

Re: can someone help me out with my mechman alt install

Postby c 45 » Mon Apr 02, 2012 6:47 am

did you get this taken care of yet ? you deff need the 1/0 from the alt to the batt and also had a question where did you get ur hids? pics ????
Colt 45
sacramento
1988 alltrac
c 45
Club Member
 
Posts: 44
Joined: Mon Mar 05, 2012 9:23 pm
Location: sacramento

Re: can someone help me out with my mechman alt install

Postby lalojamesliz » Mon Apr 02, 2012 12:58 pm

I just got off from my job and I'm waiting for mechman to open in just over a hour iirc then hopefully ill be able to start my all-trac. This is where I bought my hid's and this is the kit I have
http://www.theretrofitsource.com/produc ... cts_id=205.
took me a long time to adjust them to not blind oncoming drivers and I'm more than happy with the output
http://static.photobucket.com/player.sw ... -25-40.mp4
User avatar
lalojamesliz
Club Member
 
Posts: 222
Images: 0
Joined: Sat Jan 03, 2009 8:14 am
Location: Bakersfield,CA

Re: can someone help me out with my mechman alt install

Postby underscore » Mon Apr 02, 2012 1:30 pm

if you bought monster cable you're already wasting your money, my $0.02
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3819
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: can someone help me out with my mechman alt install

Postby lalojamesliz » Tue Apr 03, 2012 7:08 am

That crossed my mind as well..... I bought 25' of 1/0 when I relocated my battery a couple years ago and used it for the main power wire and the grounds but I was only doing what I saw others doing when they relocated their batteries also but hey with my stock 70 amp alt I'm sure it was ok. Now that I have a Alternator that puts out 156 amps at idle (800rpm) and 171 amps max (if my car needs it) I was thinking of just getting some 1/0 welding cable. I don't know if it be better though and don't want to spend $75+ on the welding cable if its not needed
User avatar
lalojamesliz
Club Member
 
Posts: 222
Images: 0
Joined: Sat Jan 03, 2009 8:14 am
Location: Bakersfield,CA

Re: can someone help me out with my mechman alt install

Postby mikecole89 » Sat Jun 02, 2012 1:12 am

This might be a little old sorry for the bump though I would post for future references. Ground the casing to the body. run 0 awg + and - to battery might be some what different since picture is from a 5s


Image

Uploaded with ImageShack.us
mikecole89
Newbie
 
Posts: 5
Joined: Sat Jun 02, 2012 12:53 am


Return to Audio / Wiring / Interior

Who is online

Users browsing this forum: No registered users and 1 guest