Page 1 of 1

slow to respond tachometer

PostPosted: Sat Nov 04, 2017 2:22 pm
by celicadude93
Just curious if anyone has come across this problem. I noticed the other day that the tachometer is very very slow to respond. I know about what rpm about i should be at going certain speeds and accelerating etc... but the tach never reaches where i should be and is just sluggish to do anything. Wondering if you guys think it's more of a cluster issue or sensor on the trans issue. any feedback is appreciated. Thanks

Re: slow to respond tachometer

PostPosted: Sun Nov 05, 2017 5:44 am
by JRWperformance
The tach gets the signal from the ignition/ECU. Might have some crunchy solder joints in the cluster. I've fixed a few things on my 165 by reflowing and adding good solder to the pins in the cluster and my climate control. Just reflow everything your soldering iron can touch. Over time, the solder joints can develop little cracks. Reflowing fixes this. It might help your dash.

Re: slow to respond tachometer

PostPosted: Sun Nov 05, 2017 12:54 pm
by celicadude93
JRWperformance wrote:The tach gets the signal from the ignition/ECU. Might have some crunchy solder joints in the cluster. I've fixed a few things on my 165 by reflowing and adding good solder to the pins in the cluster and my climate control. Just reflow everything your soldering iron can touch. Over time, the solder joints can develop little cracks. Reflowing fixes this. It might help your dash.

Thanks! I'll look into doing that over winter

Re: slow to respond tachometer

PostPosted: Sun Nov 05, 2017 10:31 pm
by yyonline
There are 2 capacitors on the tach that like to die: viewtopic.php?f=49&p=465638

Re: slow to respond tachometer

PostPosted: Mon Nov 20, 2017 12:06 am
by celicadude93
yyonline wrote:There are 2 capacitors on the tach that like to die: viewtopic.php?f=49&p=465638

Thanks man! I think that's exactly what the problem is. I will head to my local electronics store and pick up those parts and complete that repair. The description is exactly what mine is and plus it gives me the excuse to change the bulbs out to leds.