DO NOT GO TO LIGHTSPEED OF STL

The heartland

DO NOT GO TO LIGHTSPEED OF STL

Postby sirscrtm » Wed Jul 13, 2005 1:28 am

My car has been down for over a month due to these f-cks. Seems that when they changed the clutch on the car, they f-cked up on the slave cylder installation, and didnt fix it!

There are 2 bolt holes that bolts the slave cylinder to the transmission on my car. Of the 2 bolt holes, one is stripped, and the other bolt hole has a broken bolt in it. Ive tried tapping new threads but, there is not enough space to tap in new threads so my only option is to drop the transmission. Im going to have to shell out between 300-400 dollars in new tools and labor to get this fixxed, Im trying to do all the dirty work myself to keep it on the cheap, but they definitly f-cked my car up.

I just want all the other people on this forum to be aware of Lightspeed, as this is not the first time theyve screwed up on one of my familys cars before. I vouched never to go to them a long before this happened, but when my brother got a downpipe, he was by no means mechanically inclined, so he paid Lightspeed 90 dollars to fix it.

Later on when we had to remove that downpipe, they didnt swap out the old gasket, they just put a new one on top of the old one, causing an exhaust leak.

Then when they had to weld the egt probe into his exhaust manifold, instead they needlessly put a new hole in his downpipe, and they didnt even weld it on correctly. My brother found the egt probe dragging on the ground about a month later due to a shoddy weld job.

I wish these stories werent true, but they all are, they dont even treat there repeat customers with respect, they still manage to screw up every job theyve performed on our cars in everyway.

I did not have them do the clutch, I am having to fix there mistake from the last owner, if you live in st.louis, have lightspeed work on your car at your own risk.
Members don't see the above ad. Register now - it's free!
sirscrtm
Club Member
 
Posts: 166
Joined: Wed Jul 13, 2005 1:27 am

Re: DO NOT GO TO LIGHTSPEED OF STL

Postby 2of81 » Tue Aug 09, 2005 10:44 pm

sirscrtm wrote:
There are 2 bolt holes that bolts the slave cylinder to the transmission on my car. Of the 2 bolt holes, one is stripped, and the other bolt hole has a broken bolt in it. Ive tried tapping new threads but, there is not enough space to tap in new threads so my only option is to drop the transmission. Im going to have to shell out between 300-400 dollars in new tools and labor to get this fixxed, Im trying to do all the dirty work myself to keep it on the cheap, but they definitly f-cked my car up.



Did you try to tap the one out without the radiator in? I would rather pull the radiator than droping the ENGINE and TRANS....in a All-Trac. also use a very small cresent on the tap.
Somebody with a MIG welder and enough time oughta weld nuts onto the broken bolt to get it out.
Justin
1972 Corolla TE27
1993 Celica All-Trac Red-205 trans,550's, ROM Tune,20G,264 cams.
1993 Celica All-Trac White-sold to Towels
User avatar
2of81
Established Member
 
Posts: 1374
Joined: Mon Aug 09, 2004 3:18 am
Location: Kansas

Postby sirscrtm » Fri Aug 19, 2005 11:31 pm

Sorry, this is an MR2 Turbo not an alltrac. Should of clarified that, but I figured we were like bros, so you know.
sirscrtm
Club Member
 
Posts: 166
Joined: Wed Jul 13, 2005 1:27 am

Postby Ryan31783 » Mon Jan 16, 2006 4:35 pm

yet another reason as to why NOT to go to lightspeed...

A couple years ago I bought a turbo timer harness from them PN TT14-11 that they claimed would fit the Celica 87-92 and alltrac ...it doesn't. They say that it was an improper installation and I didn't know what i was doing basically. I have successfully wired in a TT harness for my old 91 mr2 turbo, with no probs, I know how to do it. The proper PN is TT 14-13, they wouldn't listen to me. They will not give me an exchange for the right part or money back. STAY THE HELL AWAY FROM LIGHTSPEED!!!

http://www.alltrac.net/phpBB2/viewtopic ... 2b8a2d900e

Ryan
'90 All-Trac Turbo
Ryan31783
Club Member
 
Posts: 57
Joined: Mon Nov 28, 2005 4:55 am

Postby nauboey04 » Sun Jan 29, 2006 9:44 pm

Sounds like some amatures work at light speed...but i hear alot of bad stuff about them even in columbia.
J.D.
Abilene, TX
'90 ST-185!!!
User avatar
nauboey04
Club Member
 
Posts: 34
Joined: Fri Nov 18, 2005 10:24 am
Location: Mizzouri, Columbia


Return to Midwest/Tx

Who is online

Users browsing this forum: No registered users and 1 guest

cron