Engine oil?

New members MUST post a new intro thread before they can access the rest of the forum.

Postby db » Thu Oct 26, 2006 3:17 pm

muneo wrote:You mean, temps go below 32 degrees? Sorry, born and raised in LA, I've never experience such a thing :P

I wasnt disagreeing with you about the cold temps/5w-30 part, I was just saying that, in my LA experience, I went through much less oil using 10w vs. 5w. I also noticed that my car ran crappy or crappier using 5w. Must be my rings and massive blow by. I do have 180K on the car.


Heh. I had mentioned it based on actually freezing temperatures. Not temps that feel cold to people who live in warmer than average climates (like you and me now).

North Dakota has a stint during winter where the temp drops to -20 or more F as a low, and has -10F as a high. Lasts a few weeks a year. Even the 5w30 feels like molasses on startup. Once warmed up 5w30 and 10w30 should work identically. Makes me wonder if your crappy running experience was caused by something else or if you were using a crappy oil brand.

My car has 205,000 and some odd miles. :D My car definitely works as a high mileage test mule.
Members don't see the above ad. Register now - it's free!
Dave
Black 1990 Celica Alltrac
2011 Ford Fusion SE (Daily driver)
2008 Harley-Davidson Street Bob
Las Vegas, NV
http://www.facebook.com/ethinos
Image
db
Established Member
 
Posts: 2177
Joined: Mon Aug 16, 2004 9:20 pm
Location: Las Vegas, NV

Postby Gary ST165 » Thu Oct 26, 2006 3:55 pm

a useful link: "how to install an oilcooler" by Mike Kelly of the GT-Four Drivers Club.

http://www.gt4dc.co.uk/website/howtos/o ... nstall.php
ST165 turbo 4WD
ST185 GT-FOUR RC Carlos Sainz Limited Edition 825•5000
ST185 turbo 4WD Carlos Sainz Limited Edition 2541•5000

Image
User avatar
Gary ST165
Established Member
 
Posts: 1524
Images: 0
Joined: Sun Jan 01, 2006 10:11 pm
Location: United Kingdom

Postby smog7 » Thu Oct 26, 2006 5:42 pm

are their any "ester" based oils in the market here in the U.S.?
-omar
my car doesn't leak oil, it just marks its territory
rally tarmac 1990 st185
User avatar
smog7
GTFour God
 
Posts: 3025
Joined: Wed Sep 27, 2006 8:34 pm
Location: central coast, ca

Postby muneo » Fri Oct 27, 2006 5:36 pm

Makes me wonder if your crappy running experience was caused by something else or if you were using a crappy oil brand.


There are so many possible culprits that its would take me a while to hunt down. All I'm certain of is that my car runs really crappy with 5w and/or if I have more than 2500 miles on my oil. Even after 1500, my oil is pretty dark by then...yeah, I got problems...

I found my car likes Mobil High Mileage 7000 10w-30
Ex-185 Owner
muneo
Established Member
 
Posts: 1003
Joined: Mon Aug 09, 2004 6:54 pm
Location: Los Angeles

Previous

Return to New Member Forum

Who is online

Users browsing this forum: No registered users and 1 guest