4 PSI boost :( limp mode??

General Chat

4 PSI boost :( limp mode??

Postby st165fan » Thu Jul 11, 2013 5:45 pm

Hey guys so this is freshly rebuilt engine and i havent been able to make over 4 psi... before rebuild it was 12-15ish. i have a MBC and one side of my wastegate actuator is capped. ive been looking through tonnes of other posts but cant find any that apply. is this some sort of limp mode?? i can take pictures of anything you may need or relay info. please help me! no one knows our engines like we do!
Members don't see the above ad. Register now - it's free!
st165fan
Newbie
 
Posts: 11
Joined: Tue Jul 24, 2012 8:36 pm

1988 Toyota Celica

Re: 4 PSI boost :( limp mode??

Postby underscore » Fri Jul 12, 2013 2:37 am

When my RC was in limp mode it was capped at 4psi, I'd assume this is the same for all of them.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: 4 PSI boost :( limp mode??

Postby st165fan » Fri Jul 12, 2013 3:40 pm

why was your in limp mode? im out of ideas as to what has occured. the PO did alot of cheap mods so im slowly weeding them out but right now im stumped :(
st165fan
Newbie
 
Posts: 11
Joined: Tue Jul 24, 2012 8:36 pm

1988 Toyota Celica

Re: 4 PSI boost :( limp mode??

Postby underscore » Sat Jul 13, 2013 2:38 am

My WTA level float was bad, resulting in a CEL and limp mode.

Still beat a supercharged B18 Civic running 10psi though...
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: 4 PSI boost :( limp mode??

Postby Theman88b » Thu Sep 19, 2013 12:02 am

I know it has been a while but did you figure out the issue? If you are running a manual boost controller straight from the wastegate actuator to the compressor then the limp mode should not apply, at least limp boost, timing may still be a factor. Basically you have bypassed the switching valve that opens the wastegate early due to limp mode.
'88 Toyota Celica All Trac Turbo(Blue) 145k - Rebuilt and Bored 1mm over, big psi soon!!
'92 Ford Taurus SHO(White) 212k - Some mods but still my DD
User avatar
Theman88b
Club Member
 
Posts: 100
Images: 3
Joined: Mon May 16, 2011 1:01 am
Location: Centennial, CO

1988 Toyota Celica

Re: 4 PSI boost :( limp mode??

Postby underscore » Sun Sep 22, 2013 4:12 pm

The TVSV can only drop it to 7psi in 3/4/5 by deciding not to bleed off pressure, that's it as far as I know, I'm not sure how it drops to 4psi.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: 4 PSI boost :( limp mode??

Postby zblu81 » Sat Oct 19, 2013 12:00 pm

I belive if you bypass your MBC by running a hose directly from the compressor to the wastegate you should get wastegate pressure, Around 7-8 PSI. If that works there could be wrong with your MBC maybe? although I don't know how a MBC could actually reduce boost pressure.

Or I think if you capped both the wastegate port and the compressor port your boost would only be limited by what the turbo is capable of (and maybe fuel cut)
[b][/b]Greg
Lansing, MI
'92 turbo All-Trac
3" Exhaust, RC intercooler, ATS TD06-20g, stage2 clutch
zblu81
Club Member
 
Posts: 579
Joined: Sun Aug 08, 2004 4:40 pm
Location: Lansing, MI

Re: 4 PSI boost :( limp mode??

Postby underscore » Sat Oct 19, 2013 3:12 pm

I think it uses other method to reduce the boost to 4psi, as the TVSV can only increase boost.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: 4 PSI boost :( limp mode??

Postby zblu81 » Sat Oct 19, 2013 7:19 pm

Could be. I was just making suggestions of things he could try to see if the MBC is working.
[b][/b]Greg
Lansing, MI
'92 turbo All-Trac
3" Exhaust, RC intercooler, ATS TD06-20g, stage2 clutch
zblu81
Club Member
 
Posts: 579
Joined: Sun Aug 08, 2004 4:40 pm
Location: Lansing, MI


Return to Club Chat

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest