Project Autobot

Talk about your project car here

Project Autobot

Postby Autobot » Sun May 11, 2008 6:51 pm

History:

I had wanted to buy an All-Trac since high school but never had the funds. When I was searching for my first vehicle in '02, I had actually passed on my All-Trac with only 95, 000 kms on it because of the price tag ($12, 999 through a Toyota dealership in Winnipeg). I ended up buying a '92 Celica GT but always regretted passing up the Trac. In late March '05 Larry Klassen mentioned that his car would possibly be up for sale. I picked up his car for $9500 in May '05, after 2 months of negotiation. It had 140, 000 kms, RC front bumper, K&N filter, JDM tranny, stock engine, System 10, leather, updated A/C, new front struts & springs and no rust.

Image

Image
Members don't see the above ad. Register now - it's free!
Last edited by Autobot on Sun May 11, 2008 7:12 pm, edited 1 time in total.
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 7:10 pm

After sorting out satefy inspection documents, the car was on the road in June '05. Then, one week after insuring the car, tragedy stuck. The engine started knocking and moments later the car died. I ended up buying a JDM engine from Tokyo Motor Imports in Montreal and picked up a new Aussie downpipe from a board member. By August '05 I was back on the road.

JDM Engine:
Image

Aussie Downpipe:
Image
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 7:19 pm

Pics after engine install:

Image

Image

Image

Image

Image

Image

Image

Image

Image
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 7:42 pm

Changed the rims, signal lights and corner lights:

Image

Image

Image

Image
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 7:43 pm

I drove the car for one month, then in September '05, tragedy stuck again. While on the highway, a black bear cub came out onto the opposite lane. I slowed down to 70 km/hr, and hit it at the front driver's side. The hood crumpled up, blocking my view and steam immediately came out of the engine bay. The car was still running, so I pulled over onto the shoulder. I managed to catch a ride home, 500 kms away. The insurance company told me they would only pay to have it towed to the nearest shop so after work, I went down with some friends, loaded it onto a trailer owned by my boss and brought it home. After haggling with the insurance company, I wrote the car off for $11,600 and bought it back for $1500.

Pics after the journey home:

Image

Image

Image

Image
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 7:49 pm

Over the next 11 months from September '05 to August '06, I searched for replacement parts and brought the car to the body shop to get all the work done. At that time, the battery was relocated to the trunk. I picked up a new RC bumper from the dealership and managed to find a damaged RC hood from Snowbird.

Image

Image

Image
Last edited by Autobot on Sun May 11, 2008 8:16 pm, edited 1 time in total.
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 7:53 pm

$6500 later, the Trac was back on the road in August '06. Also put on 92-93 taillights and hood trim.

Image

Image

Image

Image

Image
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 8:12 pm

Parked the car for the winter of '06. In '07, I painted my All-Trac hood off my GT black and installed it for a lack of WTA intercooler. I changed the emblems on the rear:

Image

Image

I installed the JDM rain guards:

Image

I upgraded the stereo to the Kenwood KDC-717DVD head unit and added a Pioneer sub and amp. Perfect fit when the screen is open, it doesn't hit the shifter or A/C controls. Stock System 10 door subs, speakers and amp still function as well.

Image

Image

I also installed the ACE Engineering rear strut tower brace. An Autostart car alarm/remote starter was also installed.
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Autobot » Sun May 11, 2008 8:30 pm

I drove the Trac during the winter of '07. A friend crashed into my GT with his sled, so I had no choice. I had problems with the battery dying and found the culprit to be the alternator. I purchased a new alternator from Strike Auto in Winnipeg and saw that they were working on Lamard's white ST185. After accumulating a few parts, I decided to bring my car to Strike Auto in February '08 to have everything installed while I had 10 days off work. My turbo had blown after hitting the bear and I found a new CT27 turbo and got the parts for a WTA intercooler set-up. The shop owner Jon found a faulty head gasket and the head was sent out to be cleaned up. What I had planned to be a simple install has turned out to be 2 months of waiting for new parts to arrive while my car sits in the shop engine-less. New pics soon...
Last edited by Autobot on Sun May 11, 2008 9:37 pm, edited 1 time in total.
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby syko says » Sun May 11, 2008 8:43 pm

great read! I remember your car being hit by a bear, but never saw pics of the car. Glad youre okay though. Youve had several unfortunate instances and I find it great youve stuck with her the whole way through!
Aloha,
Evan

RedCelicaTRD wrote:I've got my eye on you wise guy :|
User avatar
syko says
Established Member
 
Posts: 2307
Joined: Thu Mar 23, 2006 5:27 pm
Location: Waipahu, Hawaii

Postby RedCelicaTRD » Sun May 11, 2008 8:50 pm

Kinda hard to tell from the pics, but I'll have to assume the stereo is installed in the lower slot? Also, can you open and close it with the shifter in 1,3 or 5th?
Wayne
1990 All Trac
2017 SRT Challenger Hellcat
Grumpy Moderator
RedCelicaTRD
GTFour God
 
Posts: 3947
Joined: Sun Aug 08, 2004 6:58 pm
Location: Syracuse, UT

Postby Corey » Sun May 11, 2008 9:06 pm

Wow, thats quite the recovery. Nicely done :)

Did you have the stock steel bumper bar installed, or the RC aluminum one when the bear hit the car?
Image
User avatar
Corey
GTFour God
 
Posts: 4118
Images: 49
Joined: Sun Feb 11, 2007 12:12 am

1989 Toyota Celica

Postby Hotrodhendrix » Sun May 11, 2008 9:31 pm

Nice recovery. Looks great! Got any pics of the rain guards on the car from a distance?
"The more you let life's obstacles slow you down the longer it will take to defeat them."
~Yours truly
User avatar
Hotrodhendrix
GTFour God
 
Posts: 3480
Joined: Thu Sep 16, 2004 5:45 pm
Location: DFW Texas

Postby Autobot » Sun May 11, 2008 9:47 pm

RedCelicaTRD wrote:Kinda hard to tell from the pics, but I'll have to assume the stereo is installed in the lower slot? Also, can you open and close it with the shifter in 1,3 or 5th?


Yep, installed in the lower slot. The screen doesn't clear the shifter when opening or closing though. I usually leave it open when shifting. It clears for 2nd, 4th, and reverse.

Corey Darling wrote:Did you have the stock steel bumper bar installed, or the RC aluminum one when the bear hit the car?


I had the aluminum RC bumper support bar when the bear hit the car. I still have it on there. The bear managed to hit the bumper and hood and come up over the bar, leaving the frame intact.

Hotrodhendrix wrote:Got any pics of the rain guards on the car from a distance?


I only took a few dark pics while in the garage, I'll have to see if the new pics I took last weekend turn out ok. I reinstalled Windows and I forgot the install CD for my camera in the car, just had to download the program. :doh:
Image

Image
User avatar
Autobot
Established Member
 
Posts: 1810
Joined: Fri Jan 28, 2005 10:53 pm
Location: Manitoba, Canada

Postby Gary » Sun May 11, 2008 10:17 pm

Great job! :)
I remembered the bear story....
93 ST185
Image
Gary
GTFour God
 
Posts: 6430
Joined: Sun Aug 08, 2004 1:03 pm
Location: Carolina

Next

Return to My Project

Who is online

Users browsing this forum: FC Zach, FlannelFairlady and 2 guests

cron