Missing Fuel Pump Fuse / Relay?!

JDM GT Four, ST185RC and ST205.

Missing Fuel Pump Fuse / Relay?!

Postby Angrysquirel » Thu Feb 17, 2011 4:27 pm

Hello,
There has been something that has been driving me nuts about the fuse box in the engine bay of my 93 ST185.
Shortly after I bought it, I went through and examined the finer parts and internals for weak spots or things that would need attention. I found in the fuse box under the marking for "Fuel Pump" the female connector for the fuse / relay was all burnt and melted!!
This doesnt seem to effect operation at all though.
Is the fuel pump now directly supplied power at all times? How would I verify this?
Thanks all!
Members don't see the above ad. Register now - it's free!
"As a matter of deductive logic, Norman... we die down here"
User avatar
Angrysquirel
Newbie
 
Posts: 18
Joined: Thu Feb 17, 2011 12:40 am
Location: The Twisted Nether

Re: Missing Fuel Pump Fuse / Relay?!

Postby McKenzieJr18 » Sun Feb 20, 2011 3:12 am

turn on the ignition and you will hear the pump run for a coupe sec then it should turn off if not its wired to run constantly
92 alltrac 3rd gen 3s
McKenzieJr18
Club Member
 
Posts: 258
Joined: Wed Mar 25, 2009 10:49 pm

Re: Missing Fuel Pump Fuse / Relay?!

Postby Angrysquirel » Sun May 15, 2011 3:39 pm

Thanks - Relay is there, was just wired outside of the fuse box :)

THREAD CLOSED - THX
"As a matter of deductive logic, Norman... we die down here"
User avatar
Angrysquirel
Newbie
 
Posts: 18
Joined: Thu Feb 17, 2011 12:40 am
Location: The Twisted Nether


Return to GT Four Chat

Who is online

Users browsing this forum: No registered users and 1 guest