Injectors...

JDM GT Four, ST185RC and ST205.

Injectors...

Postby bluescapegoat » Mon Jul 06, 2015 2:57 am

Ok I bought an ST185 recently that was listed on this site. It had a LOT of problems. I have fixed most. But the big one I'm having is it's only running on cylinders 1-2-3. I pulled the injectors to send them off to WitchHunter for cleaning and #4 isn't even the same color. Wtf? Has this single injector been replaced in the past, is it discolored from not firing, was it defective to begin with, or maybe just a different batch of plastic in manufacturing and it's pure coincidence it doesn't work? I don't want to spend $100 to have 3 injectors cleaned when one is garbage anyway. I'd happily order all new ones, but I like the thought of keeping running on the factory originals...

Image
Members don't see the above ad. Register now - it's free!
bluescapegoat
Club Member
 
Posts: 21
Joined: Sat Mar 28, 2015 1:27 am
Location: Lakeville MN

Re: Injectors...

Postby klue » Tue Jul 07, 2015 12:40 am

probably a wiring issue, did you check that all the injectors are getting a pulse?
facebook.com/xiiimotorsports
#xiiimotorsports ON instagram
User avatar
klue
GTFour God
 
Posts: 3893
Joined: Thu Nov 04, 2004 9:47 pm
Location: Greater Toronto Area

Re: Injectors...

Postby bluescapegoat » Tue Jul 07, 2015 4:26 pm

No, I didn't. I'm learning as I go. After further studying the injectors, #4 is definitely a different brand, quality does not look nearly as good.

All I checked was the resistance in each injector.

What would be the easiest way to check that they're getting the appropriate signal?

Also, might be worth noting that I am not getting any engine codes
bluescapegoat
Club Member
 
Posts: 21
Joined: Sat Mar 28, 2015 1:27 am
Location: Lakeville MN

Re: Injectors...

Postby klue » Wed Jul 08, 2015 1:13 am

if you have everything hooked up, you can get whats called a "noid light" it clips into the connector for the injecot and lights up when the injector gets a pulse. After that its just a matter of cranking it over and seeing if it lights up.

Second to that if the car will run on three cylinders. you can disconnect each plug until you find one that doesnt make a change in the way the engine runs. Then you know which cylinder isnt working.
facebook.com/xiiimotorsports
#xiiimotorsports ON instagram
User avatar
klue
GTFour God
 
Posts: 3893
Joined: Thu Nov 04, 2004 9:47 pm
Location: Greater Toronto Area

Re: Injectors...

Postby bluescapegoat » Wed Jul 22, 2015 2:57 pm

Got the injectors back on Monday, they were all good, but did clean up a little.

I'm got a friend coming over on Saturday, going to do some diagnosing.

Thanks for the help.
bluescapegoat
Club Member
 
Posts: 21
Joined: Sat Mar 28, 2015 1:27 am
Location: Lakeville MN

Re: Injectors...

Postby MacGyver » Wed Jul 22, 2015 3:58 pm

What part of OH are you in?
MacGyver
Club Member
 
Posts: 201
Joined: Mon Dec 13, 2004 9:02 pm
Location: Cleveland, Oh

Re: Injectors...

Postby bluescapegoat » Wed Jul 22, 2015 6:51 pm

Brunswick.

I was just starting to reinstall the injectors and I can't find the fuel rail isolator for the #4 injector. Either I lost it, or its been missing all along. Seems like that could explain the issues ive been having.

Off to the dealership in the morning.
bluescapegoat
Club Member
 
Posts: 21
Joined: Sat Mar 28, 2015 1:27 am
Location: Lakeville MN

Re: Injectors...

Postby bluescapegoat » Sun Jul 26, 2015 6:10 pm

Injectors are fine. #4 was not getting a signal. Solenoid resistor tests fine. Wires from injector to ECU test fine. ECU not sending a signal to pulse the #4 injector. Looking for a 91 ECU.
bluescapegoat
Club Member
 
Posts: 21
Joined: Sat Mar 28, 2015 1:27 am
Location: Lakeville MN


Return to GT Four Chat

Who is online

Users browsing this forum: No registered users and 1 guest