Relay clicking noise, won't start

JDM GT Four, ST185RC and ST205.

Relay clicking noise, won't start

Postby Twincam.22 » Sat Feb 13, 2016 8:10 pm

Hi guys,

Tried to bring my celiac (92 gt4 Carlos Sainz) out for a spin today and it started to die after about 10 secs no matter what I did.

Thought was low on fuel so filled it up.

Tried again and same problem died on me after starting.
Now when I turn on ignition I am getting a whole load of clicking noise from behind the engine around the inlet manifold and engine will turn over but will not start.

Everything was A1 before today I only had it out 2 weeks ago and ran perfect....

Any ideas?..I'm thinking fuel pump connection maybe?
Members don't see the above ad. Register now - it's free!
Twincam.22
Club Member
 
Posts: 37
Joined: Wed Sep 24, 2014 10:39 am

Re: Relay clicking noise, won't start

Postby Twincam.22 » Mon Feb 15, 2016 9:45 pm

This evening I noticed the engine light is not coming on with ignition on I checked the fuses and all seem good.
When I check the main Ecu relay I can see it switches when ignition is on so that seems fine. Pretty stumped here now on what else to check...any ideas?

Also crossed the pins to check fuel pump and I can hear the fuel flushing back so that's ruled out....
Twincam.22
Club Member
 
Posts: 37
Joined: Wed Sep 24, 2014 10:39 am

Re: Relay clicking noise, won't start

Postby Corey » Mon Feb 15, 2016 11:25 pm

If its getting fuel, maybe it's not getting a spark?

Any CEL codes?
Image
User avatar
Corey
GTFour God
 
Posts: 4118
Images: 49
Joined: Sun Feb 11, 2007 12:12 am

1989 Toyota Celica

Re: Relay clicking noise, won't start

Postby underscore » Sun Feb 21, 2016 1:56 pm

If the CEL isn't coming on I'd correct that first, if you can pull any codes from it that'll help you a lot. Stupid questions first have you checked the bulb?
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3792
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: Relay clicking noise, won't start

Postby DonMuscles » Sun Feb 21, 2016 11:25 pm

If it is turning over and not firing and you have fuel, then it is no spark!

A clicking noise may be a broken igniter wire or wire to/from the coil, grounding on something it should not be!

Could also be a cracked dizzy cap, jumping outside of the case and grounding on the engine.
DonMuscles
Club Member
 
Posts: 33
Images: 0
Joined: Wed May 13, 2015 4:28 pm

Re: Relay clicking noise, won't start

Postby DonMuscles » Sun Feb 21, 2016 11:27 pm

Also as a first rule.... DO NOT ASSUME THAT BECAUSE A FUSE "LOOKS OKAY", that it is good!

Replace with a new one anyway!

That is the only way to be sure!


I learnt that the hard way!
DonMuscles
Club Member
 
Posts: 33
Images: 0
Joined: Wed May 13, 2015 4:28 pm

Re: Relay clicking noise, won't start

Postby underscore » Mon Feb 22, 2016 3:18 pm

^ and the second rule is that just because something is new, does not guarantee it is working. Parts are DOA all the time.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3792
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: Relay clicking noise, won't start

Postby DonMuscles » Mon Feb 22, 2016 5:10 pm

Yep!

Agreed there!!!!

Especially starter motors!!!

Had 3 faulty ones supplied in a row, before getting a good one!
DonMuscles
Club Member
 
Posts: 33
Images: 0
Joined: Wed May 13, 2015 4:28 pm

Re: Relay clicking noise, won't start

Postby DonMuscles » Mon Feb 22, 2016 5:11 pm

That was on a Fiat though......

><.
DonMuscles
Club Member
 
Posts: 33
Images: 0
Joined: Wed May 13, 2015 4:28 pm

Re: Relay clicking noise, won't start

Postby jeffdsanderson_uk » Tue Feb 23, 2016 7:18 am

This is very similar to a problem I had on the CS and other folk are getting similar problems over here in the UK. ECU capaciter breakdown!
Check out this thread covering a recent failure.
http://www.gt4dc.co.uk/forum/viewtopic.php?f=13&t=7561
jeffdsanderson_uk
Newbie
 
Posts: 11
Joined: Fri Jan 29, 2016 3:55 pm

Re: Relay clicking noise, won't start

Postby underscore » Tue Feb 23, 2016 8:41 am

Good call, the caps in our car are getting to be that age. Maybe I should replace the ones in my spare ECU now so I have a nice solid spare for when they start going in the car.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3792
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: Relay clicking noise, won't start

Postby jeffdsanderson_uk » Tue Feb 23, 2016 10:05 am

Just realised it is the same guy! ... sorry twincam :)
jeffdsanderson_uk
Newbie
 
Posts: 11
Joined: Fri Jan 29, 2016 3:55 pm

Re: Relay clicking noise, won't start

Postby Twincam.22 » Mon Mar 07, 2016 10:22 am

Guys sorry for the delayed response on this have been out of country and solve problem on another forum.

The problem was leaking capacitors on the ECU. Seems to be a common problem and luckily a quick fix was possible.
Some good info here for any guys experiencing same issues...

http://www.gt4dc.co.uk/forum/viewtopic. ... 1&start=15

thanks for all the help...
Twincam.22
Club Member
 
Posts: 37
Joined: Wed Sep 24, 2014 10:39 am


Return to GT Four Chat

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests

cron