turbosmart mbc...need help

Q&A regarding engines, turbos, and intercoolers and power upgrades

Postby spoolin_gt » Fri Oct 08, 2004 4:12 pm

sorry for asking..but how much psi is 1.1 bar??
Members don't see the above ad. Register now - it's free!
spoolin_gt
Club Member
 
Posts: 99
Joined: Thu Oct 07, 2004 3:04 pm
Location: toronto

Postby sleeper » Fri Oct 08, 2004 6:40 pm

I got the dual stage bc from turbosmart to.... and also have a problem with this....get 0.8bar on 1st and 2, 0.9 on 3, and 1.1 on 4 gear.... (t34 turbo w cusom manifoil...( wierd)
sleeper
Club Member
 
Posts: 888
Joined: Mon Aug 23, 2004 7:56 am
Location: Norway

Postby GREAT_GTS » Fri Oct 08, 2004 7:24 pm

spoolin_gt wrote:sorry for asking..but how much psi is 1.1 bar??

1 bar = 14.5 psi
so 1.1 Bar is 16 psi
'90 Celica GTS with 2nd gen 3SGTE, FMIC, 3" Full Custom Exhaust, Intake cone filter, Turbosmart BOV and FCD,Full Carlos Sainz look.
Image
GREAT_GTS
Newbie
 
Posts: 11
Joined: Thu Sep 09, 2004 4:50 am
Location: GREECE

Postby spoolin_gt » Sun Oct 10, 2004 10:44 pm

it's not that bad compare to mine...1st gear at 10psi...2nd gear...15psi @3000rpm...and 20psi@5000rpm....
spoolin_gt
Club Member
 
Posts: 99
Joined: Thu Oct 07, 2004 3:04 pm
Location: toronto

Postby alltracman78 » Thu Oct 14, 2004 10:59 pm

spoolin_gt wrote:what do you mean by the end that isn't connected to the bc???the boost controller is in between the turbo and the wastegate...and both ends are connected...


You have 2 vaccum lines. Line one connects to the wg actuator, and the bc. Line two connects to the bc and .......?
Image
User avatar
alltracman78
GTFour God
 
Posts: 4677
Joined: Mon Aug 09, 2004 9:04 am
Location: Ma

Postby spoolin_gt » Fri Oct 15, 2004 1:38 pm

turbo.... :shrug:
spoolin_gt
Club Member
 
Posts: 99
Joined: Thu Oct 07, 2004 3:04 pm
Location: toronto

Postby alltracman78 » Fri Oct 15, 2004 1:45 pm

Is that where it's connected to?
I was trying to see if you had it connected to the wrong place. Turbo is good.
Image
User avatar
alltracman78
GTFour God
 
Posts: 4677
Joined: Mon Aug 09, 2004 9:04 am
Location: Ma

Postby spoolin_gt » Fri Oct 15, 2004 5:58 pm

i think i know what it is...i dismantled the bc this morning...and found out the the ball bearing is pretty much stuck in the hole..i think cuz of grease and dirt....so i cleaned it up....put it back together...now..i just need to install it on the car again..and see how it goes...i'll keep you guys updated...thanks for all the input....
spoolin_gt
Club Member
 
Posts: 99
Joined: Thu Oct 07, 2004 3:04 pm
Location: toronto

Postby strracerx » Fri Oct 15, 2004 7:46 pm

that might be your problem. what it sounds like is that your getting a unlimited amount of boost, and as you switch gears your your under more load so it creates more boost. its either your bal bearing or you have the hoses switched which in turn causes the actuator not to open up and regulate boost.
Robert
1988 st165
San Diego
StrRacerX@cox.net
strracerx
Club Member
 
Posts: 39
Joined: Sun Sep 19, 2004 4:47 pm
Location: san diego

Previous

Return to Performance and Power

Who is online

Users browsing this forum: No registered users and 2 guests