FMIC Problems

Q&A regarding engines, turbos, and intercoolers and power upgrades

Postby gt4tified » Tue Dec 19, 2006 8:24 pm

Maybe that's just it...its easier to stall the turbo when not at full boost rather than at full boost...so maybe that's why it flutters at 3200rpm and not at anything higher?
Members don't see the above ad. Register now - it's free!
ST185 JDM GT-FOUR RC- "White Trash"
[url=http://imageshack.us][img]http://img231.imageshack.us/img231/8264/dynographsmallstretchedmu9.jpg[/img][/url]
gt4tified
GTFour God
 
Posts: 3151
Images: 5
Joined: Wed Mar 30, 2005 3:22 pm
Location: Trinidad, W.I.

Postby donteatbugs » Thu Dec 21, 2006 12:41 pm

thats what i was thinking. that and i need a bigger turbo.
Image
donteatbugs
Club Member
 
Posts: 664
Joined: Sun Sep 18, 2005 4:08 am
Location: Monroeville AL

Postby alltracst185 » Sun Jan 14, 2007 9:20 pm

i just bought the bayarea kit off ebay i hope i don't run into any problems like this!! but good thing my brother welds and owns a welder for the bov :D
st185- HKS exhaust, Aussie mid pipe and custom 3" down pipe, Tial 50mm BOV, HKS 272 cams, HKS adj cam gears, custom FMIC, HKS GT3040, Tial 38mm wastegate, AEM ems, fully built bottom end, RC 1200cc injectors, at 25 lbs and almost complete :D
User avatar
alltracst185
Established Member
 
Posts: 2994
Joined: Sun Jan 14, 2007 8:27 pm
Location: Fitchburg, MA

Postby alltracst185 » Sun Jan 28, 2007 3:44 pm

ok so now i have this problem...wtf..whell i still have to get the bov on....did any1 cure they're shuttering problems for good?
st185- HKS exhaust, Aussie mid pipe and custom 3" down pipe, Tial 50mm BOV, HKS 272 cams, HKS adj cam gears, custom FMIC, HKS GT3040, Tial 38mm wastegate, AEM ems, fully built bottom end, RC 1200cc injectors, at 25 lbs and almost complete :D
User avatar
alltracst185
Established Member
 
Posts: 2994
Joined: Sun Jan 14, 2007 8:27 pm
Location: Fitchburg, MA

Postby SeanGTS » Sun Jan 28, 2007 5:33 pm

Well, I'll be running another turbo/exhaust manifold setup here soon, should have it running again by spring break. Will see how it runs then with the new engine and other goodies.

Sean
Master Swapper
User avatar
SeanGTS
Club Member
 
Posts: 645
Joined: Fri Sep 24, 2004 5:11 am
Location: Portland, Oregon

Postby alltracst185 » Sun Jan 28, 2007 5:56 pm

i just figured it out,if ur runnin a straight intake just adjust it to as far as u can to give the maf sensor some room to be sraight again and run a bov....hopfully it will work for u too.
st185- HKS exhaust, Aussie mid pipe and custom 3" down pipe, Tial 50mm BOV, HKS 272 cams, HKS adj cam gears, custom FMIC, HKS GT3040, Tial 38mm wastegate, AEM ems, fully built bottom end, RC 1200cc injectors, at 25 lbs and almost complete :D
User avatar
alltracst185
Established Member
 
Posts: 2994
Joined: Sun Jan 14, 2007 8:27 pm
Location: Fitchburg, MA

Postby gearhead313 » Mon Jan 29, 2007 1:29 pm

alltracst185 wrote:i just figured it out,if ur runnin a straight intake just adjust it to as far as u can to give the maf sensor some room to be sraight again and run a bov....hopfully it will work for u too.



are you talking about turning the adjustment in the afm under the cover?
ST165 counter:
#2597 - fail
#3193 - fail
#xxxx - sold
#4598 - sold to Canada eh
[img]http://img.photobucket.com/albums/v123/gearhead313/turbosticker.jpg[/img]
User avatar
gearhead313
Established Member
 
Posts: 1358
Joined: Tue Aug 10, 2004 8:17 pm
Location: Pittsburgh, PA

1988 Toyota Celica

Postby alltracst185 » Mon Jan 29, 2007 5:13 pm

no,just put the maf sensor back to it's origenal position just lower because of the straight intake.(riteside up).it stopped alot of the shuttering.so hopefully putting the bov on will completely elliminate the shuttering.
st185- HKS exhaust, Aussie mid pipe and custom 3" down pipe, Tial 50mm BOV, HKS 272 cams, HKS adj cam gears, custom FMIC, HKS GT3040, Tial 38mm wastegate, AEM ems, fully built bottom end, RC 1200cc injectors, at 25 lbs and almost complete :D
User avatar
alltracst185
Established Member
 
Posts: 2994
Joined: Sun Jan 14, 2007 8:27 pm
Location: Fitchburg, MA

Postby donteatbugs » Mon Jan 29, 2007 9:24 pm

thats good to hear. mine is booting much better with the stock turbo now. sean, what turbo you plan on running?
Image
donteatbugs
Club Member
 
Posts: 664
Joined: Sun Sep 18, 2005 4:08 am
Location: Monroeville AL

Postby SeanGTS » Tue Jan 30, 2007 12:00 am

Garrett T3/T04E 54 trim, .60 AR

Just assembling the transmission again, had to swap the differentials out.
Master Swapper
User avatar
SeanGTS
Club Member
 
Posts: 645
Joined: Fri Sep 24, 2004 5:11 am
Location: Portland, Oregon

Postby donteatbugs » Tue Jan 30, 2007 11:31 am

im not looking forward to that. im buying an rc trans to put in my alltrac and it will be the first time ive had this engine out so it will probablly be heck to get out.
Image
donteatbugs
Club Member
 
Posts: 664
Joined: Sun Sep 18, 2005 4:08 am
Location: Monroeville AL

Postby turbocelica » Tue Jan 30, 2007 6:34 pm

that is a cheap turbo and manifold you are going too.... haha jk! :twisted:
Image
turbocelica
Club Member
 
Posts: 697
Joined: Wed Feb 23, 2005 6:39 am
Location: cincinnati

Postby SeanGTS » Sat Feb 03, 2007 6:10 pm

:D
Master Swapper
User avatar
SeanGTS
Club Member
 
Posts: 645
Joined: Fri Sep 24, 2004 5:11 am
Location: Portland, Oregon

Postby alltracst185 » Mon Feb 12, 2007 12:25 am

ya so i finaly got the bov installed and it still has a very slight shutter,enough to drive me crazy :twisted:

i've put my air flow sensor mounted straight again.
and installed a hks ssq bov.

do u think i should try to adjust the bov? :shrug:
has anyone figured out the cure for the shutter?and if so on what year all trac?
st185- HKS exhaust, Aussie mid pipe and custom 3" down pipe, Tial 50mm BOV, HKS 272 cams, HKS adj cam gears, custom FMIC, HKS GT3040, Tial 38mm wastegate, AEM ems, fully built bottom end, RC 1200cc injectors, at 25 lbs and almost complete :D
User avatar
alltracst185
Established Member
 
Posts: 2994
Joined: Sun Jan 14, 2007 8:27 pm
Location: Fitchburg, MA

Postby donteatbugs » Mon Feb 12, 2007 12:04 pm

mine quit after i installed a audi bypass valve and a good stock turbo and pressure checked it to 25psi.
Image
donteatbugs
Club Member
 
Posts: 664
Joined: Sun Sep 18, 2005 4:08 am
Location: Monroeville AL

PreviousNext

Return to Performance and Power

Who is online

Users browsing this forum: Bing [Bot] and 1 guest