ST165 code 54 fix (I searched)

Q&A regarding engines, turbos, and intercoolers and power upgrades

ST165 code 54 fix (I searched)

Postby knowitalls » Sat Nov 09, 2013 5:14 am

Well When I got the car it came without the inter cooler and the motor was in pieces. So I did a front mount and have CEL code 54. I ready every post that I could find on this issue, but none were able to tell me what exactly I need to do. Do I have to go to the ECU? Can I just do it from the plugs that used to plug into the pump and level indicator? Do you ground it like some say or do you put a resistor in? What do these plugs look like?

Thanks guys,
K
Members don't see the above ad. Register now - it's free!
If you didn't build it, it ain't yours.
knowitalls
Club Member
 
Posts: 80
Images: 0
Joined: Tue Aug 06, 2013 2:21 am
Location: Ramona, CA

Re: ST165 code 54 fix (I searched)

Postby brutekiller787 » Sat Nov 09, 2013 11:23 am

Step one bend paper clip to u shape

Step two jumper level connector

Step three wrap in electrical tape

Cheers
brutekiller787
Club Member
 
Posts: 371
Joined: Wed Oct 26, 2011 7:27 pm
Location: Lima, oh

Re: ST165 code 54 fix (I searched)

Postby knowitalls » Sat Nov 09, 2013 11:02 pm

brutekiller787 wrote:Step one bend paper clip to u shape

Step two jumper level connector

Step three wrap in electrical tape

Cheers


What does the plug look like? Anyone have a pic?
If you didn't build it, it ain't yours.
knowitalls
Club Member
 
Posts: 80
Images: 0
Joined: Tue Aug 06, 2013 2:21 am
Location: Ramona, CA

Re: ST165 code 54 fix (I searched)

Postby brutekiller787 » Sun Nov 10, 2013 1:21 pm

One horizontal connector on top of one vertical. Plugs into the intercooler. Comes out of the harness with the coolant temp sensors around the coolant outlet elbow. Black plug. I dont have a picture though.

Should be the only unplugged two wire connector near the coolant elbow

Hope that helps
brutekiller787
Club Member
 
Posts: 371
Joined: Wed Oct 26, 2011 7:27 pm
Location: Lima, oh

Re: ST165 code 54 fix (I searched)

Postby wakkjobb » Sun Nov 10, 2013 3:37 pm

Best I have for now:

Image

Sensor is the rubber black/gray plug on top of the IC, its wiring goes down to the harness above the water neck. If you need more, I'll get actual pics today when I'm poking around the car.
MFIC at Rainbows and Unicorns Fabwerkz :D
Old build:
http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=27648
New build:
http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=42305
Go-Fast parts:
siliconeintakes.com
User avatar
wakkjobb
Established Member
 
Posts: 1826
Joined: Wed Feb 20, 2008 11:39 pm
Location: Colorado Springs, CO

Re: ST165 code 54 fix (I searched)

Postby wakkjobb » Mon Nov 11, 2013 2:18 am

Moar better pics:

Image

Image
MFIC at Rainbows and Unicorns Fabwerkz :D
Old build:
http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=27648
New build:
http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=42305
Go-Fast parts:
siliconeintakes.com
User avatar
wakkjobb
Established Member
 
Posts: 1826
Joined: Wed Feb 20, 2008 11:39 pm
Location: Colorado Springs, CO


Return to Performance and Power

Who is online

Users browsing this forum: No registered users and 3 guests