bad turbo?

Q&A regarding engines, turbos, and intercoolers and power upgrades

bad turbo?

Postby abel99 » Tue Sep 07, 2004 1:29 pm

Hi, my car have white smoke under boost and it is no power. I just check the coolant and oil, the coolant is clean and I take out the radiator cap and start engine for a while, I didn't see any bubble come out. But it burn oil, it burn around 1.5q for 1000 miles, and i find out the intake oil inside is pretty oily. I try to turn the turbo shaft, it is a little bit hard to turn but still turn smooth, i want to konw is it normal? btw. i did the compression check on last weekend, the result is 155, 170, 180 150. maybe i will try to do the test again in next weekend, because that's the first time to do this test. So, is it HG problem or bad turbo. If I buy or upgrade turbo, any other thing I need to change too? any idea or opinion is appreciate. Thanks alot and have a nice day.
Members don't see the above ad. Register now - it's free!
90 super red 185 in SFBA
abel99
Club Member
 
Posts: 56
Joined: Mon Sep 06, 2004 7:40 am

Postby Plex » Tue Sep 07, 2004 2:29 pm

your HG is bad I'd say, because between cylinders 3 and 4 there is a BIG drop in PSI (30)... then again, it could also be your rings, which in that case, its engine rebuild time.

anyone else?
..:.Red 1988 ST165 All-Trac Turbo.:..
Plex
Club Member
 
Posts: 225
Joined: Mon Aug 23, 2004 1:09 am
Location: Portland, OR


Return to Performance and Power

Who is online

Users browsing this forum: No registered users and 1 guest