ST185 power steering not keeping up

Suspension and other discussion

Re: ST185 power steering not keeping up

Postby ALLensTRAC » Wed May 07, 2014 12:31 am

I would recommend to rebuild the pump(OEM rebuild kit is cheap) remove the rack and confirm pretension spec, confirm there is zero fluid in rack boots, drain all lines and flush them with brake cleaner, clean the reservoir out, and then perform a system flush after everything is reassembled. With that many kms and no history of hydraulic system repair this is the best place to start. I've seen a few different vehicles do this in quick switchbacks and I've found debris in rack inlet screens, pump veins, and even coolers. If after all this is done and you're still experiencing it then you might look into a pump upgrade from a different model. This is kind of a long shot as Toyota doesn't list pump maximum capabilities. You would have to compare fluid pressure specs at test rpm to different models.

Oh if you do find fluid inside the rack boots I would recommend replacing the rack vs. rebuilding. I got an OEM reman for about 300$ so it's not pricey.
Members don't see the above ad. Register now - it's free!
Allen

1992 Toyota Celica Alltrac "Never ending Project"
2014 Lexus CT200h Redline/Black "Daily project"
2006 Toyota Highlander Wifes daily
User avatar
ALLensTRAC
Club Member
 
Posts: 556
Joined: Thu Dec 23, 2010 11:33 pm
Location: Sarasota,FL

Previous

Return to Handling and Braking

Who is online

Users browsing this forum: No registered users and 1 guest