Help understanding the gt4dc citcuit for code 54

Talk EMS and Computer related performance

Re: Help understanding the gt4dc citcuit for code 54

Postby CMS-GT4 » Fri Apr 13, 2012 1:42 am

Ok, so for your pump it just needs to be powered all the time, and it is done. If they did this part for you, then that is step one.

Next, you need to ground LEV at the ecu. Just have the wire come off the harness and ground it, unless you want to run it all the way to the working sensor.

Then you just need a standard 30amp relay and the 2 resistors to build the circuit like in the image. Just be careful to not fry anything. Make sure your doing the right wires etc... There is an ecu pin out in the st205 faq thread.
Members don't see the above ad. Register now - it's free!
Coldiron
92 st185 (205 swap) | 03 350Z Track (sold) | 13 Pilot | 17 Mazda3
www.noritoy.com | noritoy.deviantart.com | http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=19891
User avatar
CMS-GT4
GTSilver Member
 
Posts: 10336
Images: 7
Joined: Mon Aug 09, 2004 9:12 pm
Location: St Louis Area (IL)

1992 Toyota Celica

Re: Help understanding the gt4dc citcuit for code 54

Postby belanger33 » Fri Apr 13, 2012 4:30 pm

Alright so i understand the second part! However, how do you know that my pump
Is already running constant...
Thanks again
GT-Four RC 1991 RHD
belanger33
Club Member
 
Posts: 151
Joined: Sun Feb 19, 2012 9:43 pm
Location: Montreal,QC

Re: Help understanding the gt4dc citcuit for code 54

Postby CMS-GT4 » Fri Apr 13, 2012 4:47 pm

That's one you will have to figure out. Feel the hoses for water moving or listen to the pump. Only other options is to trace the wires and see if they go to a constant power source.
Coldiron
92 st185 (205 swap) | 03 350Z Track (sold) | 13 Pilot | 17 Mazda3
www.noritoy.com | noritoy.deviantart.com | http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=19891
User avatar
CMS-GT4
GTSilver Member
 
Posts: 10336
Images: 7
Joined: Mon Aug 09, 2004 9:12 pm
Location: St Louis Area (IL)

1992 Toyota Celica

Re: Help understanding the gt4dc citcuit for code 54

Postby belanger33 » Thu Apr 19, 2012 10:52 pm

I Have some updates....I tried the relay solution like in the diagram on the last page but with no success....At first, i thought i had it because i had no more Check engine at idle, but when i drove out the parking the light went back on... I even switched the relay thinking it might not work properly but with no sucess...the LEV is grounded at ECU also...
Any suggestions now...:(
GT-Four RC 1991 RHD
belanger33
Club Member
 
Posts: 151
Joined: Sun Feb 19, 2012 9:43 pm
Location: Montreal,QC

Re: Help understanding the gt4dc citcuit for code 54

Postby CMS-GT4 » Fri Apr 20, 2012 12:32 am

It not turning on till you drive is a sign that you grounded lev is functioning properly. It's the rest of the circuit that's the issue. Double check you built it right and check your connections for all the wires and solders.
Coldiron
92 st185 (205 swap) | 03 350Z Track (sold) | 13 Pilot | 17 Mazda3
www.noritoy.com | noritoy.deviantart.com | http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=19891
User avatar
CMS-GT4
GTSilver Member
 
Posts: 10336
Images: 7
Joined: Mon Aug 09, 2004 9:12 pm
Location: St Louis Area (IL)

1992 Toyota Celica

Re: Help understanding the gt4dc citcuit for code 54

Postby belanger33 » Tue May 08, 2012 10:44 pm

New update: i installed a new relay and it is working partially i could say! What i mean is that im getting no error code while starting the car and driving, even when i boost, however, i get one SOMETIMES when being at WOT. Other times at WOT wont bring the check engine light on too. I am wondering if it might me some resistors that are not strong enough or something else i might not know....?

Thanks again!
GT-Four RC 1991 RHD
belanger33
Club Member
 
Posts: 151
Joined: Sun Feb 19, 2012 9:43 pm
Location: Montreal,QC

Re: Help understanding the gt4dc citcuit for code 54

Postby CMS-GT4 » Wed May 09, 2012 12:16 am

It might be a loose connection maybe and the force from driving is breaking the signal? Did you check to make sure its the same error code when you pul over? It could be something else.
Coldiron
92 st185 (205 swap) | 03 350Z Track (sold) | 13 Pilot | 17 Mazda3
www.noritoy.com | noritoy.deviantart.com | http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=19891
User avatar
CMS-GT4
GTSilver Member
 
Posts: 10336
Images: 7
Joined: Mon Aug 09, 2004 9:12 pm
Location: St Louis Area (IL)

1992 Toyota Celica

Re: Help understanding the gt4dc citcuit for code 54

Postby tubasteve » Wed May 09, 2012 3:25 am

how is the win wire grounded? if to the chassi of the pcm, that will be why, i had the same problem on a customers car a few years back on a RC conversion.(not the one you shipped).

glade to hear it works.
feb. 1990 alltrac red one: fun machine http://tinyurl.com/Tubasteve
5x114 conversion: http://tinyurl.com/nu3qnez
Image
User avatar
tubasteve
Established Member
 
Posts: 1149
Joined: Tue Apr 01, 2008 6:48 pm
Location: temecula, ca(951)

Re: Help understanding the gt4dc citcuit for code 54

Postby belanger33 » Wed May 09, 2012 10:55 pm

I will have to double check the wires....i dougt being another thing since i had nothing before that check engine 54 but i'll have a look to make sure.

Tubasteve: what do you mean with the win wires?
GT-Four RC 1991 RHD
belanger33
Club Member
 
Posts: 151
Joined: Sun Feb 19, 2012 9:43 pm
Location: Montreal,QC

Re: Help understanding the gt4dc citcuit for code 54

Postby belanger33 » Tue Jun 05, 2012 12:24 am

Code 54 is gone!!! so happy that i can feel the real power of the ST205 ECU now! i changed the relay and double checked the wires and it worked afterwards!
GT-Four RC 1991 RHD
belanger33
Club Member
 
Posts: 151
Joined: Sun Feb 19, 2012 9:43 pm
Location: Montreal,QC

Re: Help understanding the gt4dc citcuit for code 54

Postby just_ace » Sun Jul 15, 2012 4:47 am

i also fitted the above relay/resistor circuit with great success. i'm running a gen3 st205 ecu and engine in my st185, but with aftermarket bosch pump running via a separate switch and relay. i used a patch loom and implemented the relay/resistors to at the patch loom.

no CEL and runs perfectly with 16psi from a gt2560 turbo

cheers guys. :D now i can give my broinlaw his sw20 ecu back.
just_ace
Newbie
 
Posts: 8
Joined: Tue Mar 22, 2011 5:31 am

Re: Help understanding the gt4dc citcuit for code 54

Postby aus jd 2703 » Sun Jul 15, 2012 4:54 am

i didnt think you could chaNGE TURBO'S ON THE GEN 3 ECU?
thought it screwed it up and ran lean in patches?
aus jd 2703
Established Member
 
Posts: 1089
Joined: Wed Apr 30, 2008 12:02 am

Re: Help understanding the gt4dc citcuit for code 54

Postby just_ace » Sun Jul 15, 2012 4:58 am

depends on what turbo really. (this is getting Off topic tho) the gt2560 is pretty similar to the ct20b flow wise. the stock ECU runs rich above 4000rpm anyhow, so a little bit leaner is good :)
just_ace
Newbie
 
Posts: 8
Joined: Tue Mar 22, 2011 5:31 am

Re: Help understanding the gt4dc citcuit for code 54

Postby turbocelica » Mon Jun 10, 2013 3:23 am

okay after reading this thread im really confused, can someone state exactly what is needed to do to make sure this goes away.

st205 ecu, st205 motor, st185 harness. prolly gonna go either fmic or aftermarket intercooler pump.

Thanks.
Image
turbocelica
Club Member
 
Posts: 697
Joined: Wed Feb 23, 2005 6:39 am
Location: cincinnati

Re: Help understanding the gt4dc citcuit for code 54

Postby CMS-GT4 » Mon Jun 10, 2013 4:36 am

This is the method I used:

CMS-GT4 wrote:I followed this method.

Image

Car runs fine. I now get 9-10psi.
Error code is gone, but the light bulb from the circuit still does not light up. I hear the relay kick on when it does a pump check. Rock and roll. I test drove it. Pulls pretty well. I think it will pull even better once I install my boost guage. :evil:
Coldiron
92 st185 (205 swap) | 03 350Z Track (sold) | 13 Pilot | 17 Mazda3
www.noritoy.com | noritoy.deviantart.com | http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=19891
User avatar
CMS-GT4
GTSilver Member
 
Posts: 10336
Images: 7
Joined: Mon Aug 09, 2004 9:12 pm
Location: St Louis Area (IL)

1992 Toyota Celica

Previous

Return to EFI Corner

Who is online

Users browsing this forum: No registered users and 1 guest