Knock sensor problem

Talk EMS and Computer related performance

Knock sensor problem

Postby pinoyGT4 » Thu Sep 24, 2009 4:27 pm

my CEL turns on whenever i hit 2,300rpm.. then i can feel a sudden retardation from the car's performance..

i checked the error code with the help of a reputable mechanic here, and it says knock sensor...

hmm...

so i then replaced my knock sensor with a new one.. still, the problem persists...

then my old knock sensor was put on a 4age 20v BT with a knock sensor problem too but it worked well meaning my old sensor wasnt busted..

what do you guys think i can do to isolate the possible problem that triggers the knock sensor error? :)
Members don't see the above ad. Register now - it's free!
Image
Making your car track worthy is making it more than road worthy
www.grupotoyota.com.ph
pinoyGT4
Club Member
 
Posts: 108
Joined: Sat Sep 19, 2009 2:03 pm

Postby Mafix » Thu Sep 24, 2009 5:14 pm

BAD WIRING
Mafix
Gold Member
 
Posts: 5877
Joined: Tue Aug 10, 2004 10:56 pm

Postby siralys » Fri Sep 25, 2009 12:53 am

yup, I had to fix mine when I pulled my motor. at the worst just run a shielded wire from the sensor back to the ecu
2003 hyundai santa fe- daily driver
1995 vw passat vr6- modded wagon- sold
1988 celica alltrac- in parts finding mode
siralys
Club Member
 
Posts: 289
Joined: Sun Jun 08, 2008 5:43 pm
Location: Riegelsville, Pa- now KOP

Postby pinoyGT4 » Fri Sep 25, 2009 1:21 am

Mafix wrote:BAD WIRING


oh man.. you think so?

i had my car converted coz it came from japan RHD and here in the philippines, cars are LHD...

i guess i have to ask my mechanic to re-wire it then..

but any other problem that could trigger the said error?

@siralys: so you just ran a shielded wire from the sensor, did just that fix the problem?
Image
Making your car track worthy is making it more than road worthy
www.grupotoyota.com.ph
pinoyGT4
Club Member
 
Posts: 108
Joined: Sat Sep 19, 2009 2:03 pm

Postby gearhead313 » Thu Oct 15, 2009 11:50 pm

oh lord, the knock sensor woohs... i've gone through a ton of headaches fixing this. search and you'll see. DEFINITELY change the wire.
ST165 counter:
#2597 - fail
#3193 - fail
#xxxx - sold
#4598 - sold to Canada eh
[img]http://img.photobucket.com/albums/v123/gearhead313/turbosticker.jpg[/img]
User avatar
gearhead313
Established Member
 
Posts: 1358
Joined: Tue Aug 10, 2004 8:17 pm
Location: Pittsburgh, PA

1988 Toyota Celica

Postby pinoyGT4 » Thu Oct 22, 2009 10:06 am

gearhead313 wrote:oh lord, the knock sensor woohs... i've gone through a ton of headaches fixing this. search and you'll see. DEFINITELY change the wire.


damn.. i guess i really have to then... aright..

ill just fix my rack n pinion problem.. :(
Image
Making your car track worthy is making it more than road worthy
www.grupotoyota.com.ph
pinoyGT4
Club Member
 
Posts: 108
Joined: Sat Sep 19, 2009 2:03 pm


Return to EFI Corner

Who is online

Users browsing this forum: No registered users and 1 guest