error code 52, bad sensor cause problems?

Talk EMS and Computer related performance

error code 52, bad sensor cause problems?

Postby timco » Fri Mar 04, 2011 2:49 pm

Been having issues with acceleration hesitation and idle. I get error code 52 in diagnostics. Could a bad knock sensor cause these symptoms? I have no vacuum leaks, new fuel filter and pump. New plugs, wires, cap and Rotor. My only engine code is error 52. Thanks in advance,
Kris
Members don't see the above ad. Register now - it's free!
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby MrDB » Fri Mar 04, 2011 5:13 pm

Yes with knock sensor fault it will be basically un driveable.
Image
Car Build : [ http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=26755 ]
MrDB
Club Member
 
Posts: 393
Joined: Fri Sep 28, 2007 6:22 am

Re: error code 52, bad sensor cause problems?

Postby timco » Fri Mar 04, 2011 5:42 pm

It's drivable now, but I literally can barely do more than idle through the gears. Giving it more gas just seems to bog it down until I hit the higher rpms of the gear. Going to order the sensor from ats racing and hope it solves the problem.
Thanks a lot
Kris
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby Gary ST165 » Fri Mar 04, 2011 6:06 pm

code 52

blown knock sensor, from to much boost or critical knock event
or it could be a break in the wiring between KS to ECU.

If you reset the ECU ( pull EFI fuse) you can drive / rev until about 2800 before the engine management light will come on and retard performance to "safe mode"
ST165 turbo 4WD
ST185 GT-FOUR RC Carlos Sainz Limited Edition 825•5000
ST185 turbo 4WD Carlos Sainz Limited Edition 2541•5000

Image
User avatar
Gary ST165
Established Member
 
Posts: 1524
Images: 0
Joined: Sun Jan 01, 2006 10:11 pm
Location: United Kingdom

Re: error code 52, bad sensor cause problems?

Postby timco » Fri Mar 04, 2011 6:26 pm

Gary ST165 wrote:code 52

blown knock sensor, from to much boost or critical knock event
or it could be a break in the wiring between KS to ECU.

If you reset the ECU ( pull EFI fuse) you can drive / rev until about 2800 before the engine management light will come on and retard performance to "safe mode"



From what I read the stock knock sensor is pretty fragile. Ordered a new one today. Hope it solves my issue. Until it comes in is it safe to keep driving and just go easy on it? Thanks for the help.
Kris.
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby Gary ST165 » Fri Mar 04, 2011 6:44 pm

the knock sensor is not fragile... many last for 20+years without issue

but poor tuning will kill it



you certainly shouldn't boost with out KS!
...and as i said you can nurse the car up to 2800 rpm :D so it is still driveable. just.
ST165 turbo 4WD
ST185 GT-FOUR RC Carlos Sainz Limited Edition 825•5000
ST185 turbo 4WD Carlos Sainz Limited Edition 2541•5000

Image
User avatar
Gary ST165
Established Member
 
Posts: 1524
Images: 0
Joined: Sun Jan 01, 2006 10:11 pm
Location: United Kingdom

Re: error code 52, bad sensor cause problems?

Postby timco » Fri Mar 04, 2011 7:05 pm

Gary ST165 wrote:the knock sensor is not fragile... many last for 20+years without issue

but poor tuning will kill it



you certainly shouldn't boost with out KS!
...and as i said you can nurse the car up to 2800 rpm :D so it is still driveable. just.


Guess my car us 20 yrs oldish. Whoever swapped the engine and ecu did a terrible job so I assume it was never dyno tested. Looks like someone got into ahurry to drive it and just threw everything together so I'm left with working it all out. I'll baby it and get that new sensor installed as soon as it arrives. Crossing my fingers that it will solve my problems. Been replacing everything.
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby timco » Fri Mar 04, 2011 9:44 pm

Cleared the codes with removal of the EFI fuse once, then the neg bat cable once. Even after that I start up and the engine light just stays on constantly. Even if i havent revved over idle. Only code is the code 52 as of now. I spoke with 5th gear motorsports they insist that replacing the knock sensor wont do me any good. Their only advice was to get a new wiring harness.... hoping like mad that this isnt the case : (
Kris
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby timco » Sat Mar 05, 2011 3:59 pm

Gary ST165 wrote:code 52

blown knock sensor, from to much boost or critical knock event
or it could be a break in the wiring between KS to ECU.

If you reset the ECU ( pull EFI fuse) you can drive / rev until about 2800 before the engine management light will come on and retard performance to "safe mode"



Even after resetting the fuse ill start the engine and(sometimes 30 seconds others immediately) the CEL comes back on. new knock sensor will be here this coming week hope that is the issue. Checking the wiring as of now. Another thread showing where/how to replace it scares me because the guys problem was actually a piston hitting(actual knock). I listen to it idle and hear nothing aside from valve ticks.
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby timco » Sun Mar 06, 2011 6:44 pm

Tested the continuity of the cable from the KS to the ecu. Was fine. Though I've read its a single cable from the KS to the ecu...right before the ecu mine has been spliced, one cable runs to the ecu and the other looks like it goes somewhere back into the wiring harness and I havent been able to find where. I have the cable ready to just make a new one but not sure if i need to worry about that rogue connection that just splices off. Any thoughts?
kris

edit: I removed my old KS(still dont have the new one) to check it out. It "looks" fine. Any test to see if its bad?
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby timco » Mon Mar 07, 2011 12:44 am

My buddy has a 3sgte just waiting to be swapped in to his 5th gen. I borrowed is KS and ran a new wire...car runs perfect now. Better than it has since I've had it. Thanks for all the help.
Kris
88 All Trac
2nd gen 3sgteRC
[Image
timco
Club Member
 
Posts: 89
Joined: Mon Jan 31, 2011 7:46 pm
Location: Seattle, WA

Re: error code 52, bad sensor cause problems?

Postby $1200alltrac » Tue Oct 18, 2011 6:22 pm

So if my wire is fine its definitely the knock sensor?
I like my alltrac..and its cool brand new boost guage!
$1200alltrac
Club Member
 
Posts: 88
Joined: Wed Oct 12, 2011 3:29 am

Re: error code 52, bad sensor cause problems?

Postby $1200alltrac » Mon Nov 28, 2011 2:02 am

It was the wire...code 52 means no signal from the knocksensor
I like my alltrac..and its cool brand new boost guage!
$1200alltrac
Club Member
 
Posts: 88
Joined: Wed Oct 12, 2011 3:29 am


Return to EFI Corner

Who is online

Users browsing this forum: No registered users and 1 guest