ST165 Fuel Pump constantly running, Need Help

Talk EMS and Computer related performance

ST165 Fuel Pump constantly running, Need Help

Postby GT4_Vinnie » Sun Aug 26, 2012 4:38 am

Hey guys,

So this weekend ive put back together everything on my 165, in the hopes that it would start. Upon connecting a battery (through jumper leads) the fuel pump started to run, even when the key was off and out. it would run no more then 10seconds long and switch off, only to switch on again once ignition was turned on.

I know it should only get power to it when ignition is on, also couldn't get the car to fire, or not very long if it did. Cracked the system before the injectors as couldn't reach the rail, and fuel was pissing out when pump was running, just not too sure if it was getting any to the injectors. Going to check that next.

Car hasn't been running for atleast 5 years. is there anything else to do with the fuel that would cause it not to fire and keep running. For example fuel pump relay, fuel pressure dampner, faulty fuel pump switch, if thats the problem etc.

If anyones had a similar problem, it would be great to know how you diagnosed and cured it.

I also have a few empty vacuum nipples which I have no idea where they run to, and whether they may be causing vacuum leaks or even fuel cut? Ill try get a few pics of the open vac nipples, theres a few on the intake manifold and throttle body. A couple around the A/C Idle Up Valve? and then a few around the left hand side of firewall where the Diagnostic plug is. Ive disabled the TVIS by capping the vac nipple between the cooler pipes around by the exhaust manifold. I think Ive done everything properly to.

Thanks
Vinnie
Members don't see the above ad. Register now - it's free!
Vinnie,
1988 GT4 Celica
GT4_Vinnie
Club Member
 
Posts: 102
Joined: Sun Oct 09, 2011 9:46 am

Re: ST165 Fuel Pump constantly running, Need Help

Postby GT4_Vinnie » Mon Aug 27, 2012 5:52 am

Bump, please needing any ideas to try out, Im at a loss.
Thanks
Vinnie,
1988 GT4 Celica
GT4_Vinnie
Club Member
 
Posts: 102
Joined: Sun Oct 09, 2011 9:46 am


Return to EFI Corner

Who is online

Users browsing this forum: No registered users and 1 guest

cron