Switch to full style
Talk EMS and Computer related performance
Post a reply

st165 code 11

Sat Sep 13, 2014 5:46 pm

hello, i purchased an st165 a few month ago, not running fixed some issues here and there, clocked turbo correctly it had an st185 turbo ser up on factory st165 engine with a bunch of AN fittings, leaked everywhwre did not spool, waastegate actuator wasnt on right. clocke turbo, modified actuator, so that explains code 34 over boost.
my other issue now is, u try to start the car, hold the key takes a while at least 25-30 seconds to start idles up at 1400-1500 just fine, but the minute u blip the throttle it will sound like its about to shut off and when u let it go it idles again, if u hold the throttle down over 20% it will cause this issue, if u barely touch the throttle 10-15% it will rev up smoothly.
basically its heaitating under throttle, hot or cold it will cause this issue, i put new cap rotor, same plug wires and plugs, new oil in engine and coolant flush since it was rusted, flushed water pump for turbo and for engine. ideas? i bought a spare distributor and i also switched coil pack with a good working 1. i did not use new distrubtor yet.
i also, did not ignition time the motor yet, but i know this code 11 isnt from that.
Members don't see the above ad. Register now

Re: st165 code 11

Sun Sep 14, 2014 5:00 pm

Change the fuel filter ?

Re: st165 code 11

Sun Sep 14, 2014 7:47 pm

This thread sounds similar to your problem:
http://www.yotatech.com/f116/need-help- ... rt-187562/

Over there they think it's the throttle position sensor, I don't have any personal experience with that particular problem though.

Re: st165 code 11

Mon Sep 15, 2014 4:47 pm

havent changed fuel filter, i have 1 but i wanted to flush the tank first.
and tps huh, steange usually at work any car with tps prpblema tps code comes right up

Re: st165 code 11

Thu Sep 18, 2014 11:25 am

mi645 wrote:havent changed fuel filter, i have 1 but i wanted to flush the tank first.
and tps huh, steange usually at work any car with tps prpblema tps code comes right up



Good plan on tank. Its prol crudded up like mine was ... had to have mine re-done by a gas tank shop. Lifetime Warranty :D

Re: st165 code 11

Fri Oct 17, 2014 6:17 am

ive been away from the car for a while =/ but im happy to say tomorrow im moving it to my friends place where i can actually work on it =D
i cant wait ive been just of driving it for a very long time. lucky i still have my 6th gen still running strong =] 'all i gotta say right now i love my cars and i enjoy them, so i hope everyone out their is having the same, also im in socal area, im somewhat mechanically inclined, so if anyone ever needs help around, id love to help.

Re: st165 code 11

Fri Jun 12, 2015 3:02 am

Ok so got back to work on the car, used distributor, timed to 10 advanced with t and e1 plugged. So timing is correct
, so still hard start, code 12 now, which is no rpm signal to dcu, looked under the glove box juat to see the ecu (which is under the center console actually) found a plug, that someone jumped a 4 pin wire to its self, and it hooks up to a relay , that is part number # 90987-02004 dont know what its for, but its def not factory to have this jumper wire into it. Cant find where it plugs into. Really wanna get this car running right. Help me :)

Re: st165 code 11

Sun Jun 14, 2015 3:22 pm

Behind the glove box is most likely the intercooler pump full run mod ...

Re: st165 code 11

Sun Jun 14, 2015 4:09 pm

i had a feeling its either that or the heater resistor mod. cuz my heater or ac only works in 1 speed so i know someone modified it lol. and it is true when i turn the key to the on position i can hear the ic water pump always cranking. idk if i should leave it as is? or put it back to stock. so anyways i worked on the car again, and i figured either my starter circut in the starter its self is bad. or my distributor but ive replaced that. other problems i think would be cold start injector cuz it only acts up when its cold and 10 mins later it idles ok (kind of) right now my idle is a bit off its at 1200-1500, but i reset the battery/ecu so idk if it has to relearn. egh i love this car i just want to drive it already lol

Re: st165 code 11

Sun Jun 14, 2015 4:34 pm

Cold start injectors are know to go bad , I havent had that problem on mine but alot of others have. I would leave the intercooler mod. Mines been that way for 5 years now ... better off. And as for driving it .. yeah it was almost a year and a half before I got to drive mine on the road ... :lol:

Re: st165 code 12

Sun Jun 14, 2015 11:45 pm

Today i picked up a starter, an igniter, and a bunch of interior parts i needed.
Hopefully i can get it together :(

Re: st165 code 12

Mon Jun 15, 2015 11:09 am

mi645 wrote:Today i picked up a starter, an igniter, and a bunch of interior parts i needed.
Hopefully i can get it together :(


You'll get there ... and after its on the road you'll find more shit :roll: Just the way these cars are ...

Re: st165 code 12

Mon Jun 15, 2015 2:50 pm

Lol dont say that haha, once i get it running enough to drive it to the dealership, i should be able to work on it After hours, i need a new diff bushing, lots of other bushings lol, everything is leaking so i gotta reseal everything.
Umm, i know so far the engine has been rebuilt, and it has a 2nd gen turbo and turbo manifold and down pipe (decat)
It over boosts so the cel will blink and fuel cut, so i do need a fcd

Re: st165 code 12

Mon Jul 06, 2015 12:31 am

mi645 wrote:Lol dont say that haha, once i get it running enough to drive it to the dealership, i should be able to work on it After hours, i need a new diff bushing, lots of other bushings lol, everything is leaking so i gotta reseal everything.
Umm, i know so far the engine has been rebuilt, and it has a 2nd gen turbo and turbo manifold and down pipe (decat)
It over boosts so the cel will blink and fuel cut, so i do need a fcd


I would first check for vac leaks maybe around wastegaste first. Mine use to pop the hose off the waster gate and do that. but sometimes these cars will just do that depending on the conditions. I would jump to a FCD until you go threw alot of the other crap ... I had one on mine and took it back off for now since i wasn't ready to program boost controller , exhaust not done , etc etc

Re: st165 code 11

Thu Nov 12, 2015 3:53 am

Update!!!!
So i had time to work on the car again, pulled throttle body cleaned out isc idle speed control valve,
The gasket on the isc came off, i tho i could get 1 but nope they dont make it or sell it anywhwre
So i waa forced to use some fipg, silicone, and bought a tb gasket and sure enough didnt really line up correctly, had to remove the dial pins on the tb in order to turn the gasket the correct way, then i unplugged the cold start injector, had an extra set of plugs (wrong ones) bkr7eix which are used for any 3sgte except 1st gen >_<
Bought some plugs 28 bucks, ngk laser platinum forgot the model its like cpr or something, anyways,
Now car fires up but doesnt die like it used to, only thing is it does still sputter and it sounds like its mis firing for a few seconds then smoothens out but it doesnt like throttle input if u put ur foot down it will die or idle down or bog down, it will only be smooth at 3k rpms or higher, i also replaced some vacuum hoses that were visually cracked and tearing.
Anyways my afm or intake pipe does have like 1 or 2 hoses (big hoses) not like vac hoses, that r kind of torn at the egdes or seprated. Part of me feels like its slmething to do with the tvis being stuck open, and of course car smells like its running very rich or burning oil, anyways also when the car warms up, the idle goes up between 1500-2000
And it will stay there, and rhe bogging or sputtering will go away after it warms up. And also the idle adjust screw on tb is all the way down for lowest idle setting.
So does anyone have any ideas? I even installed another turbo recenty due to my other turbo leaking oil into the intake. Im running a ct26 twin scroll ceramic exhaust.
Any input will be appreciated, and also found a gutted cat in my down pipe.
Trying to think if i found anything else? Hmm oh right, also my car will crank strange like someone doing a compression test or like the timing belt isnt on. Only block spinning. Car is very strange, just want to fix it already. >_< s
Post a reply