idle to redline in neutral....boost = sputter

Talk EMS and Computer related performance

idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Sun Oct 26, 2014 2:01 am

Ok my setup for this car I have is a ST165 us car and I installed a ST185 JDM into the car using the injectors and intake with sensors. I didn't have a AFM so I pulled one from a NA car.

At first the car wouldn't rev past 3500...sputter out like it was getting to much fuel....I pulled the plugs and verified I was getting to much fuel so I opened up the AFM and adjusted it. At about 8 clicks from stock position the car idles good and revs to redline well. When driving it's a 1/8-1/4 throttle....anything pass that equals a sputter.

I adjust it to where it's about 18 clicks from stock and it idles horribly and sometimes dies but revs nicely to redline and when driving if I slowly roll throttle I can even boost in low gears smoothly. At 60 mph I can maintain it with no problem but as soon as boos comes its a sputter. I tried doing a downshift and I carried the 4000-5000 rpm in 3rd smoothly with the response to throttle.

So basically if I set it where it doesn't idle I can NA rev well but nothing on boost and if I set it where It idles and still revs to redline it wont even hold speed at 60.

Any thoughts? I am using a Walbro 255 fuel pump......I just thought could it be as soon as I hit boost fuel pressure goes up and that's my issue?

Tuesday I'm suppose to have my wideband so I'll be able to see what's really happening.
Members don't see the above ad. Register now - it's free!
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Sun Oct 26, 2014 2:38 am

oh and my speedo isn't working.....does the car need that working to know how fast I'm driving?
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby underscore » Sun Oct 26, 2014 7:46 am

For starters get the right AFM for the ECU, you'll have a hard time getting it running right without that.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3821
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Sun Oct 26, 2014 11:24 am

Where do you get one? I've looked at the parts store and on rock auto as well as ebay. I even made a post about it like a month ago I got told a NA one would work.
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby Meenya » Sun Oct 26, 2014 5:17 pm

underscore wrote:For starters get the right AFM for the ECU, you'll have a hard time getting it running right without that.


+1

Find out what ECU do you have (part number) 90-91 is different than 92-93
Try to find out what engine do you have 92-93 came with 9 studs exhaust manifold
Look for correct AFM for your application

To add for the confusion there is also RC AFM & ECU which are different

Just because someone said NA will work, doesn't mean it will work correctly. HTH
Mike

93 Turbo 4WD
91 GTFour RC
07 R6
User avatar
Meenya
Club Member
 
Posts: 147
Images: 19
Joined: Wed Jun 15, 2011 10:07 pm
Location: Ontario

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Sun Oct 26, 2014 6:17 pm

The car is a 88 and the motor is a 91. I'm using the 88 wiring n ecm.
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Sun Oct 26, 2014 6:19 pm

Will a 91 afm work with the 88 ecu? If so I've located one.
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Sun Oct 26, 2014 6:24 pm

Heck just thought can someone tell me what part number or numbers I need to get
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby ___Scott___ » Mon Oct 27, 2014 12:37 am

Will a 91 afm work with the 88 ecu?


I'm pretty sure the 90+ AFM doesn't have the shut-off switch for the fuel pump that the 88 ECU and wiring will require. It will be obvious if you need that switch and don't have it when the engine starts fine, but then dies about 3 seconds later.
Scott
Colorado Springs, CO - USA
SONY
Opera - The better browser
User avatar
___Scott___
Established Member
 
Posts: 2067
Joined: Mon Aug 09, 2004 5:30 pm
Location: - - USA - - Colorado Springs, CO

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Mon Oct 27, 2014 12:56 am

So besides the switch it will work correct? I can work around a fuel shut off switch.
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana

Re: idle to redline in neutral....boost = sputter

Postby ___Scott___ » Mon Oct 27, 2014 3:23 am

The switch in the AFM is a safety feature that causes the fuel pump to shut off in the event of an accident that also stalls the engine. You really don't want to experience a pressure fed fuel fire, there will be enough other "excitement" in the event of an accident where a fuel line ruptures. So, you shouldn't try to work around it unless you also implement the same safety functionality.

That being said, I believe the 90+ (non-RC/CS) will work if you "hot-wire" your fuel pump relay to bypass that safety switch (though I've never done it.)
Scott
Colorado Springs, CO - USA
SONY
Opera - The better browser
User avatar
___Scott___
Established Member
 
Posts: 2067
Joined: Mon Aug 09, 2004 5:30 pm
Location: - - USA - - Colorado Springs, CO

Re: idle to redline in neutral....boost = sputter

Postby outinnowhere3193 » Mon Oct 27, 2014 10:29 am

Well we will give it a try then. Maybe I can add the switch in?.... who knows I'll figure it out n post back in.
outinnowhere3193
Club Member
 
Posts: 120
Images: 5
Joined: Mon Sep 29, 2014 1:31 pm
Location: Hymera, Indiana


Return to EFI Corner

Who is online

Users browsing this forum: No registered users and 1 guest