[How to] Check engine error code and reset the ECU

Write ups and tutorials for maintenance and modifications.

[How to] Check engine error code and reset the ECU

Postby Gary » Thu Sep 16, 2004 10:37 pm

Here is the way to check the error code.
Scroll down to see how to reset the ECU.

Click on thumbnails to view the larger images in new window.

Locating diagnostic terminal
Image

Obtaining the error code
(engine off, turn key to "ON" position)
Image

Cancelling code
Image

Error Code: 3S-GTE (page 1)
Image

Error Code: 3S-GTE (page 2)
Image

Error Code: 5S-FE (page 1)
Image

Error Code: 5S-FE (page 2)
Image

Keywords: CEL check engine light error code pull diagnostic codes

To reset the ECU
you can either:
1. Remove EFI fuse for 15 sec or longer. This is the 15A blade fuse located in the fuse box next to the battery.
This is NOT the big EFI main relay. Removing the relay will NOT reset the ECU.
2. Remove the battery terminal. Note that, when you remove the battery terminal,
your radio and clock setting will be gone too.

Note that resetting the ECU will eliminate all the error codes stored in the ECU memory.
However, if the root problem was not fixed, the error code will be back.
Members don't see the above ad. Register now - it's free!
Last edited by Gary on Fri Aug 18, 2006 4:52 pm, edited 3 times in total.
93 ST185
Image
Gary
GTFour God
 
Posts: 6430
Joined: Sun Aug 08, 2004 1:03 pm
Location: Carolina

Postby RIalltrac » Tue May 31, 2005 11:06 pm

I get the same issue, so there is definately something wrong with the link. If you have a BGB the info listed on that page is in the FI section. Use http://tracfaq.nw-celica.com/wiki/run.p ... =Reference and look it up from there if need be.
Chris - 90 ST185
User avatar
RIalltrac
GTFour God
 
Posts: 3109
Images: 2
Joined: Mon Aug 09, 2004 7:38 pm
Location: North Providence, RI

Postby moee24 » Wed Jun 01, 2005 10:22 pm

-
Last edited by moee24 on Thu Feb 19, 2009 2:18 am, edited 1 time in total.
moee24
Club Member
 
Posts: 86
Joined: Sun Aug 29, 2004 3:52 pm
Location: chicago, il

Postby SuperWhite92 » Fri Oct 21, 2005 7:04 am

which ports do you bridge for ST165's? There doesn't seem to be a TE1 terminal.
Shaun
Image
My 1992 Alltrac is for sale again.
User avatar
SuperWhite92
GTFour God
 
Posts: 3012
Joined: Sun Aug 08, 2004 3:29 pm
Location: Fort Collins, CO

Postby Gary » Fri Oct 21, 2005 11:42 am

T and E1 for ST165

Error codes for ST165

Image

Image
93 ST185
Image
Gary
GTFour God
 
Posts: 6430
Joined: Sun Aug 08, 2004 1:03 pm
Location: Carolina

Postby SuperWhite92 » Fri Oct 21, 2005 6:21 pm

Thanks gary. For some odd reason, the T terminal isn't working for us, so I guess we'll clean it out and try again.
Shaun
Image
My 1992 Alltrac is for sale again.
User avatar
SuperWhite92
GTFour God
 
Posts: 3012
Joined: Sun Aug 08, 2004 3:29 pm
Location: Fort Collins, CO

Postby BriinumsBo » Wed May 07, 2008 8:05 am

if resetting the clock means the ECU is reset then this solution might help. loosen your battery cable clip bolts and try to start the car. if the wires are loose enough, the starter will pull out all electricity of your car and wont even crank, it will be a "click" and all stuff will be off for a second. the starter just cannot get enough power from the battery because of bad wire connection.. after that just retighten the bolts and youre done ;)
User avatar
BriinumsBo
Club Member
 
Posts: 509
Joined: Tue Jun 26, 2007 12:00 pm
Location: Latvia

Postby Meurz » Sun Mar 22, 2009 9:08 pm

I've put one together as well;

http://www.turbocelica.nl/howto-errorcodes.htm

Or go to http://www.turbocelica.nl --> Tuning --> How to.. --> How to check the ECU for error codes
Turbocelica.nl
User avatar
Meurz
Established Member
 
Posts: 2189
Joined: Sat Sep 10, 2005 12:16 pm
Location: NLD

Postby Papi_Ocho » Fri May 15, 2009 3:29 pm

can someone please post a pic of the lid/cap for the test point box.

I have an 88att

thanks
Papi_Ocho
Club Member
 
Posts: 45
Joined: Sun Apr 26, 2009 12:06 pm

Postby Meurz » Fri May 15, 2009 3:49 pm

You didn't check my link?
Turbocelica.nl
User avatar
Meurz
Established Member
 
Posts: 2189
Joined: Sat Sep 10, 2005 12:16 pm
Location: NLD

Postby Papi_Ocho » Fri May 15, 2009 9:09 pm

Meurz wrote:You didn't check my link?


i sure did!
and i said to myself "y the poopoo didnt someone put a pic of the lid"

thinking that the pin diagram was on the OUTSIDE

but i look really good at your pic and DAM :| there it is UNDER the lid :lol: cool thanks u rock

i just got my factory repair manuals in the mail! i'm excited

thanks again
Papi_Ocho
Club Member
 
Posts: 45
Joined: Sun Apr 26, 2009 12:06 pm

Postby schweizerceli » Tue Oct 13, 2009 10:39 pm

Trying to check my engine codes (the check engine light is on) on my ST185 and I cannot get the light to flash nor am I able to reset it.

When I bridge the terminals in the diagnostic box, all I get is the fuel pump relay clicking.

The car runs fine and sounds healthy. The bgb troubleshooting guide tells me to try another ECU based on my findings.

Has anyone had this problem before?
[img]http://img.photobucket.com/albums/v179/89gts/zenautobanner.gif[/img]
http://www.ZenAutoworks.ca

'94 ST205 WRC - Summer Toy
'92 ST185H RC - Track Toy
'92 FD3S Type R - Garage Queen
'96 LC Prado - Daily Delivery Unit
User avatar
schweizerceli
Club Member
 
Posts: 147
Joined: Fri Aug 26, 2005 5:41 pm
Location: Calgary, Alberta, Canada

Postby shadowlife25 » Wed Oct 14, 2009 4:04 am

Sounds to me like you are jumping the terminals FP and B+ for the fuel pump relay.

Check to be sure you are jumpering the correct terminals.
- Mario
User avatar
shadowlife25
Club Member
 
Posts: 400
Joined: Sun Feb 18, 2007 3:26 am
Location: Napa, CA.

Postby GT4RC » Wed Oct 14, 2009 7:03 am

*snicker*
User avatar
GT4RC
Established Member
 
Posts: 1258
Joined: Tue Mar 15, 2005 7:02 pm
Location: Edmonton, AB

Postby schweizerceli » Wed Oct 14, 2009 1:28 pm

:| Snicker away but I'm quite possitive I'm jumpering the correct terminals. TE1 and E1 ...

I'll go back to it on Friday here.
[img]http://img.photobucket.com/albums/v179/89gts/zenautobanner.gif[/img]
http://www.ZenAutoworks.ca

'94 ST205 WRC - Summer Toy
'92 ST185H RC - Track Toy
'92 FD3S Type R - Garage Queen
'96 LC Prado - Daily Delivery Unit
User avatar
schweizerceli
Club Member
 
Posts: 147
Joined: Fri Aug 26, 2005 5:41 pm
Location: Calgary, Alberta, Canada

Next

Return to How To

Who is online

Users browsing this forum: No registered users and 3 guests