engine boggs at high rpm (SOLVED)

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

Re: engine boggs at high rpm

Postby yamayuki98 » Tue Apr 06, 2010 2:26 am

sorry to post so late. been working like a mad man. well, i'll be getting a couple of days off all to myself this week so i will check the compression. here is what i found out new. the engine seems to rev up to redline perfectly fine if i part throttle say around 85 percent, but if wot then it hesitates and struggles. so i test this by running wot and the minute its boggs i reduce the throttle slightly, the car picks up again and run all the way to redline. boost fine too.???
Members don't see the above ad. Register now - it's free!
91' platinum silver celica alltrac
CA
yamayuki98
Club Member
 
Posts: 231
Joined: Wed Aug 11, 2004 10:11 pm
Location: Fresno, CA

Re: engine boggs at high rpm (SOLVED)

Postby yamayuki98 » Wed Apr 07, 2010 11:53 pm

thanks everyone for all your help and suggestions. it turns out that the one vacuum that was not on the diagram (the one that comes out on the side of the throttle and hooks straight to the valve cover)was old and expanded so it kept loosing vacuum pressure. this line just happens to carry a lot of vacuum, a main line i believe. i hooked up a vac pump to it and notice that my vacuum was around 16-17, telling me that i had vac leak somewhere. so i started pinch off vac lines and came upon this particular one that was not listed int he diagram. sure enough when i removed it and plugged it with a new new vacuum shot up to 19 and stood there constant. took the car for a spin and viola. boosting and everything again. hoo-ray.
91' platinum silver celica alltrac
CA
yamayuki98
Club Member
 
Posts: 231
Joined: Wed Aug 11, 2004 10:11 pm
Location: Fresno, CA

Re: engine boggs at high rpm (SOLVED)

Postby MWP » Fri Apr 09, 2010 12:35 am

Thats a tiny hose... im very surprised that a split in it would have that much of an effect.
Good to hear you found the problem though.
My collection of GT4 documentation: http://gt4.mwp.id.au
Daily: Celica GT4 ST185 (~170kw/atw)
Project: Toyota RA28 '77 Celica (1UZ-FE powered)
Chairman of the SA Classic Celica Club.
MWP
Established Member
 
Posts: 1591
Joined: Mon Jun 01, 2009 11:02 am
Location: Adelaide, South Australia

Re: engine boggs at high rpm (SOLVED)

Postby Rallly » Sun Sep 03, 2017 6:45 pm

yamayuki98 wrote:thanks everyone for all your help and suggestions. it turns out that the one vacuum that was not on the diagram (the one that comes out on the side of the throttle and hooks straight to the valve cover)was old and expanded so it kept loosing vacuum pressure. this line just happens to carry a lot of vacuum, a main line i believe. i hooked up a vac pump to it and notice that my vacuum was around 16-17, telling me that i had vac leak somewhere. so i started pinch off vac lines and came upon this particular one that was not listed int he diagram. sure enough when i removed it and plugged it with a new new vacuum shot up to 19 and stood there constant. took the car for a spin and viola. boosting and everything again. hoo-ray.



Can you send a pic to ralllysport1@msn.com which vac hose it was please?
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Previous

Return to General Maintenance and Repair

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 1 guest