Wont start after driving for a while..

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

Wont start after driving for a while..

Postby maxaud » Sat Jul 13, 2013 2:08 am

So a while back my Celica would randomly shut off after driving it long distance or if I shut it off after a little drive, it wouldn't start again until it was left sitting for a bit.

The fuel pump relay also seemed like it would get considerably hot, maybe that's normal?
(I've tried a different relay as well.)

I took it to a shop and they said it was the fuel pump so I ordered a walbro and had that put it.

It's been working fine for a while now and probably have put on a few hundred kilometers but now it's doing the same thing.
sometimes the car will also take a few rotations of the engine to start where it will normally start right up.

I'm curious if anyone has had a similar issue and what it ended up being, or if anyone knows what may be causing this.

I would hate to have another fuel pump put in as I feel like that's not the solution. Maybe there's something inline that is causing the pump to overheat? I can still hear the pump turn on when turning the key (not everytime).

Thoughts?

Thanks, as always, guys.
Members don't see the above ad. Register now - it's free!
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby underscore » Sat Jul 13, 2013 2:22 am

I believe this is what the starter relay mod is supposed to fix.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: Wont start after driving for a while..

Postby maxaud » Sat Jul 13, 2013 2:32 am

The car still turns over, quiet well at that too.
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby maxaud » Sat Jul 13, 2013 2:48 am

Yeah, reading up on the starter relay mod (and the associated problem), it doesn't sound like the same thing. The car tuns over quiet well and doesn't click at all. The part about having to let the car sit does sound reminiscent of the starter relay mod issue though.

Thanks for the suggestion.
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby syko says » Sun Jul 14, 2013 5:17 am

perhaps maybe the afm? When I had my 185, I think I could drive it while cold/warmed up; but typically after 30 min the car would shut off after stopping completely then trying to accelerate. it threw some CELs related to the afm. Opened it up and found the connections were loose. It's worthwhile to look at it, if you can seal it up.
Aloha,
Evan

RedCelicaTRD wrote:I've got my eye on you wise guy :|
User avatar
syko says
Established Member
 
Posts: 2307
Joined: Thu Mar 23, 2006 5:27 pm
Location: Waipahu, Hawaii

Re: Wont start after driving for a while..

Postby maxaud » Sun Jul 14, 2013 6:03 am

I'm not getting any codes related to AFM but I suppose that doesn't rule it out.

I also noticed that the blue/yellow wire to the fuel pump relay looks a little glazed as if it were getting some resistance.
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby syko says » Sun Jul 14, 2013 6:34 am

with the cars being so old, it could be old connections or wires that could heat up and lose contact; even if its minor resistance. if no CELs, your afm prob is good. Good luck on the RC (if its still running strong?)
Aloha,
Evan

RedCelicaTRD wrote:I've got my eye on you wise guy :|
User avatar
syko says
Established Member
 
Posts: 2307
Joined: Thu Mar 23, 2006 5:27 pm
Location: Waipahu, Hawaii

Re: Wont start after driving for a while..

Postby maxaud » Sun Jul 14, 2013 2:59 pm

Besides the intermittent not wanting to start it's doing great.

Thank you.
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby Bobbyx661 » Sun Jul 14, 2013 5:12 pm

mine did the same thing and after changing everything out it turned out that I just needed colder plugs -_- so id try that man.
User avatar
Bobbyx661
Club Member
 
Posts: 24
Images: 8
Joined: Sat Oct 27, 2012 5:00 am

1993 Toyota Celica

Re: Wont start after driving for a while..

Postby Corey » Sun Jul 14, 2013 5:34 pm

My car had strange starting issues for the longest time. I'd have to crank and crank before it would fire up. Some days it would have no issues.

What fixed it - no idea. But I can tell you what I changed.

Gen III MR2 ECU
Gen III Air temp sensors, Map sensor and Ignitor
AFM - GONE
st205 Injectors
tvis no longer needed - removed
cold start injector no longer needed - removed


nothing else changed. The car now fires right up. Wiring harness is still original (just repinned for the MR2 ecu with a jumper)

Now it fires up like a brand new car.
Image
User avatar
Corey
GTFour God
 
Posts: 4121
Images: 50
Joined: Sun Feb 11, 2007 12:12 am

1989 Toyota Celica

Re: Wont start after driving for a while..

Postby maxaud » Sun Jul 14, 2013 6:06 pm

Thanks guys, I'll be doing a tune up here soon and will most likely get the NGK BKR7E's, should be cold enough, right?
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby maxaud » Wed Nov 04, 2015 5:49 pm

Bringing this thread back to life. Been a while since I've been on.

STILL having this issue.

Basically, if I drive any long distance or if I drive the car for longer than 30-40 minutes and I shut it off it wont want to start. Simply turns over and doesn't even sound like it's trying to start.

Was told it may be vapor lock in the fuel system but I still encountered the issue with the fuel cap off.

Seems to be fuel related instead of spark.

Any other ideas as to what this may be?
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby ___Scott___ » Thu Nov 05, 2015 1:48 am

Fuel filter?
Scott
Colorado Springs, CO - USA
SONY
Opera - The better browser
User avatar
___Scott___
Established Member
 
Posts: 2064
Joined: Mon Aug 09, 2004 5:30 pm
Location: - - USA - - Colorado Springs, CO

Re: Wont start after driving for a while..

Postby maxaud » Thu Nov 05, 2015 4:00 pm

Do you thinka fuel filter would prevent it from even coughing while turning over? If you let it sit it then starts right up..
-Dustin
Image
User avatar
maxaud
GTFour God
 
Posts: 3306
Joined: Sun Jul 10, 2005 4:33 pm
Location: Sandpoint, Idaho, USA

1992 Toyota Celica

Re: Wont start after driving for a while..

Postby ___Scott___ » Thu Nov 05, 2015 5:04 pm

My Mom had a '76 Celica GT (many years ago) that did the same thing. My memory isn't real clear on the details, but I do remember replacing the fuel filter. It also seems that there was a blockage in the fuel line that we had to blow out.

Before that it would run fine for a while and then just shut off. It gradually got worse until I replaced the fuel filter and blew out the fuel line. No trouble after that (other than that even though it didn't leak a drop of anything, it did burn a quart of oil every 100 miles on the highway.)

That was a cool car, I wish I was in a position to buy it before they traded it in.
Scott
Colorado Springs, CO - USA
SONY
Opera - The better browser
User avatar
___Scott___
Established Member
 
Posts: 2064
Joined: Mon Aug 09, 2004 5:30 pm
Location: - - USA - - Colorado Springs, CO

Next

Return to General Maintenance and Repair

Who is online

Users browsing this forum: Google Adsense [Bot] and 2 guests