TVIS Actuator Repair

From Tune Ups to Oil Changes, maintenance related

Moderator: toayoztan

TVIS Actuator Repair

Postby ___Scott___ » Sat Jun 11, 2016 4:23 am

While I had my car apart, I checked to see if the TVIS actuator was working. To no great surprise I found that I could easily suck air through the diaphragm. A little googling for a fix turned up a post on mr2oc.com (I think) where someone cut the actuator open and smeared silicone over the diaphragm then used sheet metal screws to put it back together.

That seemed like a good idea but I didn't like the screws so I used a cut-off wheel on my die grinder to cut tabs while I was cutting it open. The metal is very thin and cuts easily so be careful to not cut too deep.

Image

Then I smeared Ultra Black silicone (my personal favorite sealer for these types of things) all over the diaphragm. When it dried, I applied a little more silicone around the edge of the cover and set it in place then bent the tabs down to keep it there. DON'T FORGET to install the spring (I forgot but remembered before the silicone dried so it was easy to open back up and put the spring in.)
Image

Before I put it back in, I smeared more silicone around the perimeter to make double-sure it was sealed and to cover the sharp edges that I was too lazy to smooth out.
Image
Members don't see the above ad. Register now - it's free!
Scott
Colorado Springs, CO - USA
SONY
Opera - The better browser
User avatar
___Scott___
Established Member
 
Posts: 2064
Joined: Mon Aug 09, 2004 5:30 pm
Location: - - USA - - Colorado Springs, CO

Re: TVIS Actuator Repair

Postby underscore » Sat Jun 11, 2016 7:25 am

Neat idea, looks a lot easier than modifying something to work.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: TVIS Actuator Repair

Postby ___Scott___ » Sun Sep 24, 2017 5:05 am

Just a quick update. The fix shown above only worked for about a year. When I heard a whistling noise I tracked it to that diaphram. Since that's a tough thing to work on with the engine in the car, I just pulled the vacuum hose from the intake and capped the port. That leaves the T-VIS plates wide open all the time, but it seems to run better that way anyway so it works for me.
Scott
Colorado Springs, CO - USA
SONY
Opera - The better browser
User avatar
___Scott___
Established Member
 
Posts: 2064
Joined: Mon Aug 09, 2004 5:30 pm
Location: - - USA - - Colorado Springs, CO


Return to General Maintenance and Repair

Who is online

Users browsing this forum: No registered users and 1 guest