St185 AllTrac boosting on gauge but that's it?!

Q&A regarding engines, turbos, and intercoolers and power upgrades

St185 AllTrac boosting on gauge but that's it?!

Postby Rallly » Tue Sep 05, 2017 10:59 pm

91 Celica AllTrac. Runs fine, idles perfect. Just had timing belt done and timing was set to spec 10 deg.

Was doing these symptoms before but now more than ever after the timing belt job.

So Under WOT it bucks/hesitates like crazy, hot or cold. Boosts to 14psi and I can hear the turbo spool but no power! Takes for ever to hit 100kmh.

What should I do?
Members don't see the above ad. Register now - it's free!
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Re: St185 AllTrac boosting on gauge but that's it?!

Postby Mr Alltrac » Tue Sep 05, 2017 11:13 pm

Do you have a fuel cut defender? If it's the stock 2nd gen motor you probably hit fuel cut and your car is in limp mode. IIRC 12 psi is the most that car will do without fueling mods.
Mr Alltrac
Club Member
 
Posts: 440
Images: 0
Joined: Sun Dec 01, 2013 10:35 pm

Re: St185 AllTrac boosting on gauge but that's it?!

Postby Rallly » Tue Sep 05, 2017 11:15 pm

I have disconnected the vac hose from turbo sensor and plugged it with a screw. Someone told me on this forum that would eliminate fuel cut and boost cut.
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Re: St185 AllTrac boosting on gauge but that's it?!

Postby underscore » Wed Sep 06, 2017 2:15 pm

No CEL?
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: St185 AllTrac boosting on gauge but that's it?!

Postby Rallly » Wed Sep 06, 2017 7:24 pm

No cel....
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Re: St185 AllTrac boosting on gauge but that's it?!

Postby lalojamesliz1 » Wed Sep 06, 2017 7:46 pm

Do you have a wideband installed?
Have you done a ignition tune up?
Changed fuel filter?
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 157
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA

Re: St185 AllTrac boosting on gauge but that's it?!

Postby Rallly » Wed Sep 06, 2017 7:53 pm

No wideband, yes I have done the cap, rotor, plugs and seafoam. Just went for a drivee. Seems to operate normally at partia throttle but as soon as I go WOT boost gauge shoes full boost but certainly doesn't feel like full boost, bucking/stumbling no passing power at all.
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Re: St185 AllTrac boosting on gauge but that's it?!

Postby Rallly » Wed Sep 06, 2017 9:00 pm

So after about a 15min drive I turned car off for 10mins then went back for another drive. Car boosted much better this time, but slight back firing at high rpms. Feels flat after 5000rpm. No power really. At least I can rule out boost leak and bad turbo. There's so many sensors I just don't know what it could be?
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Re: St185 AllTrac boosting on gauge but that's it?!

Postby underscore » Wed Sep 06, 2017 9:32 pm

Do a boost leak test.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: St185 AllTrac boosting on gauge but that's it?!

Postby Rallly » Wed Sep 06, 2017 11:04 pm

Boost leak test checks out good!


Would a bad coolant temp sensor do these symptoms?
Rallly
Club Member
 
Posts: 185
Joined: Wed Jul 29, 2015 12:31 am

Re: St185 AllTrac boosting on gauge but that's it?!

Postby underscore » Thu Sep 07, 2017 4:14 am

It could be, if the ECU thinks the engine is stone cold it would probably pull timing if you punched it. Or if the cold start injector circuit is stuck on it would run really rich and bog.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3809
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC


Return to Performance and Power

Who is online

Users browsing this forum: No registered users and 5 guests