ST-185 Sluggish before turbo spools

Q&A regarding engines, turbos, and intercoolers and power upgrades

ST-185 Sluggish before turbo spools

Postby bullet781 » Tue Oct 03, 2017 12:02 pm

Probably a stupid question, but here it goes:

93 'trac, essentially bone stock with 155k miles. Newer plugs, wires, cap (18 months ago), new cat (2 weeks ago), all major services done/updated/taken care of by and large. Great car...runs really, really well.

Except for the last few weeks - whether the engine is cold or hot, engine feels like it bogs down significantly/loses power UNTIL the turbo spools and then it responds great - like always. I've done the usual checks and tests (per all the discussion I've seen and searched through in other posts in the forums) but I am stumped.

Could it be the 02 sensor? They've probably seen better days. Maybe the EGR valve? Of late, she smells like she's running a little rich.

Open to thoughts or things I should investigate and try - hopefully it's nothing major. This think has gotten a significant overhaul this year - can't afford much more!
Members don't see the above ad. Register now - it's free!
bullet781
Newbie
 
Posts: 6
Images: 0
Joined: Tue Aug 25, 2015 1:21 am

1993 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby underscore » Tue Oct 03, 2017 3:19 pm

Sounds like it's running rich, maybe the O2 sensor or a pre-O2 exhaust leak. Try unplugging the sensor and see if it gets any worse?
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3821
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: ST-185 Sluggish before turbo spools

Postby bullet781 » Wed Oct 04, 2017 12:11 am

Unplugged the O2 sensor and it’s a bit worse (driven about 25 miles disconnected). I can always replace my to see if that helps matters. Only noticed it after the cat was replaced two weeks ago - but we’ve double and triple checked and no leaks or issues with the cat thus far.
bullet781
Newbie
 
Posts: 6
Images: 0
Joined: Tue Aug 25, 2015 1:21 am

1993 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby lalojamesliz1 » Wed Oct 04, 2017 7:05 pm

Take a look at the spark plugs and if they are black on the ends your running rich and that can point at what underscore suggests.

Have you tried a compression test or leak down test?
Also , verify the engine timing
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 159
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA

Re: ST-185 Sluggish before turbo spools

Postby MADDTRD » Thu Oct 05, 2017 3:32 pm

Have you checked the compression of each cylinder?
MADDTRD
Newbie
 
Posts: 3
Joined: Mon Aug 21, 2017 7:40 pm
Location: California

1990 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby bullet781 » Mon Oct 30, 2017 5:06 pm

So as an update, we've checked all things recommended and mentioned so far in this post (thank you to all the replies) with no change in bucking at low RPM's and it's running really rich. Plugs, wires, distributor, checked/adjusted timing, etc. Disconnect the O2 sensor and it's still the same. No leaks...no smoke...once it gets going, it's fine. It's getting it going that's the problem...anything below 25 mph and it feels like it will stall. No codes or CEL. At wits end and ready to give this car up at this point. Could it be a bad ECU? Bad cold start injector (which are near impossible to find)? I see a few ECU's floating out there on eBay but can't make sense of whether one of them will be a good swap or if I should send mine in somewhere for a repair/rebuild? Open to any other suggestions, but I'm out of good ideas (and money)!
bullet781
Newbie
 
Posts: 6
Images: 0
Joined: Tue Aug 25, 2015 1:21 am

1993 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby lalojamesliz1 » Mon Oct 30, 2017 7:22 pm

bullet781 wrote:So as an update, we've checked all things recommended and mentioned so far in this post (thank you to all the replies) with no change in bucking at low RPM's and it's running really rich. Plugs, wires, distributor, checked/adjusted timing, etc. Disconnect the O2 sensor and it's still the same. No leaks...no smoke...once it gets going, it's fine. It's getting it going that's the problem...anything below 25 mph and it feels like it will stall. No codes or CEL. At wits end and ready to give this car up at this point. Could it be a bad ECU? Bad cold start injector (which are near impossible to find)? I see a few ECU's floating out there on eBay but can't make sense of whether one of them will be a good swap or if I should send mine in somewhere for a repair/rebuild? Open to any other suggestions, but I'm out of good ideas (and money)!


Have you opened your ecu to make sure you don't have any leaking capacitors or have anything burned up?
I personally don't think the cold start injector is even needed because it started fine for me when I first got my all-trac back and it had gen2 electronics on my gen3 engine (No Cold start injector). I'd try unplugging it from the fuel line and plugging that hole. I don't remember the bolt size unfortunately
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 159
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA

Re: ST-185 Sluggish before turbo spools

Postby Celi-GT4 » Tue Oct 31, 2017 1:21 am

Did you double check the timing, whats it running?? How about the t belt are the cam pullys looking lined up at
TDC? Any hanging valves?
12.4 @ 115mph Topeka Kansas NA2005
12.2 @ 109mph blew HG Moroso 1/08
Sold out, now on stock 3rd gen
Blitz ecu, dp,exhaust, tien ss, carbon driveshaft,light wheels/brakes,os giken twin plate
Celi-GT4
Club Member
 
Posts: 338
Joined: Mon Aug 09, 2004 3:45 pm
Location: Park City, Utah

Re: ST-185 Sluggish before turbo spools

Postby FC Zach » Tue Oct 31, 2017 2:54 am

I've had the exact symptoms before. . . This was years ago but I believe my AFM was the issue.
1992 Toyota Celica AllTrac
1987 Mazda RX7 Sport
1979 Yamaha G1A, rotary powered with Sachs KM24
1976 Hercules W2000, oil injected
User avatar
FC Zach
Club Member
 
Posts: 831
Images: 9
Joined: Mon May 20, 2013 7:43 am
Location: Eagleville, TN

1992 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby FC Zach » Tue Oct 31, 2017 2:57 am

I also replaced the O2 sensor around the same time, that could have been the fix. . . I don't remember for certain.
1992 Toyota Celica AllTrac
1987 Mazda RX7 Sport
1979 Yamaha G1A, rotary powered with Sachs KM24
1976 Hercules W2000, oil injected
User avatar
FC Zach
Club Member
 
Posts: 831
Images: 9
Joined: Mon May 20, 2013 7:43 am
Location: Eagleville, TN

1992 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby lalojamesliz1 » Tue Oct 31, 2017 3:17 am

The process of elimination.... sucks man.
Have a wideband? That would help I'm sure but at a price tags of like $150+
91 Celica all-trac gen3 swap
87 toy 5speed long bed
69 mustang
08 sequoia
14 avalon
and a 2 car garage :shoots:
lalojamesliz1
Club Member
 
Posts: 159
Joined: Sun Jul 23, 2017 3:03 pm
Location: Bakersfield, CA

Re: ST-185 Sluggish before turbo spools

Postby underscore » Tue Oct 31, 2017 3:57 am

Isn't there a test procedure for the MAF? I'd try that. A sticking cold start injector could also cause the car to run rich.
★ 1991 GTFour RC ~ "Rebel Scum" ★
It's for sale! http://www.alltrac.net/phpBB2/viewtopic.php?f=64&t=52181
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 3821
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: ST-185 Sluggish before turbo spools

Postby FC Zach » Tue Oct 31, 2017 4:33 am

underscore wrote:Isn't there a test procedure for the MAF?


You're helping me remember. . . There is a test procedure, an ohm meter will be needed. I recall testing mine now, I'll share the page from the manual if OP doesn't have one. . let me know.
1992 Toyota Celica AllTrac
1987 Mazda RX7 Sport
1979 Yamaha G1A, rotary powered with Sachs KM24
1976 Hercules W2000, oil injected
User avatar
FC Zach
Club Member
 
Posts: 831
Images: 9
Joined: Mon May 20, 2013 7:43 am
Location: Eagleville, TN

1992 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby bullet781 » Wed Nov 01, 2017 1:43 am

I don't have the test procedure, so if someone would be willing to post it/share it, that would be fantastic.

Pulled the new o2 sensor - it's pretty black. when it's not connected, there's no difference with the performance of the car, which is why I was wondering if there's something to do with the ECU. Ran fine for years...and then, one day, it happened. Out of nowhere...

I've heard that the cold start injectors for these cars are interchangeable between other models - if that's the case, can anyone point me in a direction to what to look for?

I'll pull the ECU next to see if there's anything burned out. How interchangeable are these? I've seen a few come out on eBay from time to time, but wasn't sure how the numbers needed to line up? Or...am I better off having it reprogrammed?
bullet781
Newbie
 
Posts: 6
Images: 0
Joined: Tue Aug 25, 2015 1:21 am

1993 Toyota Celica

Re: ST-185 Sluggish before turbo spools

Postby FC Zach » Wed Nov 01, 2017 4:15 am

bullet781 wrote:I don't have the test procedure, so if someone would be willing to post it/share it, that would be fantastic.

Will do, when I get off work in the morning I'll check the manual and share the procedure.

bullet781 wrote:Pulled the new o2 sensor - it's pretty black. when it's not connected, there's no difference with the performance of the car, which is why I was wondering if there's something to do with the ECU. Ran fine for years...and then, one day, it happened. Out of nowhere...

I'd replace this regardless. . It's a tune-up part, wont hurt.

bullet781 wrote:I'll pull the ECU next to see if there's anything burned out. How interchangeable are these? I've seen a few come out on eBay from time to time, but wasn't sure how the numbers needed to line up? Or...am I better off having it reprogrammed?

They are model/year specific so you'll need the proper part.
1992 Toyota Celica AllTrac
1987 Mazda RX7 Sport
1979 Yamaha G1A, rotary powered with Sachs KM24
1976 Hercules W2000, oil injected
User avatar
FC Zach
Club Member
 
Posts: 831
Images: 9
Joined: Mon May 20, 2013 7:43 am
Location: Eagleville, TN

1992 Toyota Celica

Next

Return to Performance and Power

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest