185 Acting Weird, running rough, no RPM


Active member
Last week my ST185H RC was running fine. Went to go move it and it didn’t want to start. Drained the fuel thinking it was maybe some bad gas. Managed to get it pulled in the garage and checked a few things.

I noticed the RPM gauge is not working.

I noticed the check engine light was on while running so I bridged E1 and TE1 and turned the key to the on position but the check engine light stayed solid. Tried with two different jumpers. It should flash non stop even if no codes are stored.

I also tried Test Mode with TE2 but that didn’t show anything either.

Replaced the igniter thinking that could be the cause of running rough and no RPM but that didn’t change anything.

Replaces the ignition coil in case that was he reason it’s running rough.

Replaced the fuel filter thinking it was bad fuel but old one was pretty clean when I took it out.

It’s very weird to my that I have no RPM and trying to check diagnostics is not working. Has me thinking it’s ECU.

Anyone have a spare 89661-2B310 ECU laying around?


Well-known member
the Tach issue is almost always the capacitors blowing behind the gauge itself if the car is running. however, with your issues, seems like something else is afoot if you've jumped the e1/te1 and are using an analog voltmeter with no codes present. you may be onto something with the ECU. i may have a stock 1992 ST185 all-trac ECU, i'll dig through my stuff. since i swapped to 4th gen and i'm about to run the ECU masters ecu, should have something if need be. are you in the states?

BTW if you don't have an analog voltmeter, get one and try this again with the jumpers attached:



Active member
It definitely sounds like the ECU, but before waiting on a replacement take it out and open it up. If the caps have leaked it'll be very obvious.