Page 1 of 1

Sticky Pedal?

PostPosted: Sun Sep 29, 2019 10:54 pm
by sefiroxx
On my 91 GT, have been experiencing what appears to be a sticky pedal, throttle, cable, other. Just started the investigation, but figured I'd post here to see if anyone has experienced.

Symptom is a binding that requires more than normal foot pressure to get "a release". This occurs on initial 1st gear only, and only periodically. Does not occur on higher gears. For 1st, it might be from stop or after cruising down to first.

On car off, I've done the simple things like check pedal, butterfly opening by pulling the the cable, the interface at the cruise control diaphram, etc. No binding.

I'm thinking it might be related to the idle screw adjustment that I made, but think that is nothing more than a little/gap rather than another stop adjustment for the butterfly.

Will plan on cleaning the butterfly and throttle body, but figured I'd check here as well.

- GT/5SFE
- 330,000
- Original pedal, cable, throttle etc
- Cruise control
- Known issue with IAC (not closing completely, idle adjustment screw (not stop screw) turned down completely to correct for idle adjustment)

Re: Sticky Pedal?

PostPosted: Thu Oct 03, 2019 5:02 pm
by 93celicaconv
sefiroxx wrote:On my 91 GT, have been experiencing what appears to be a sticky pedal, throttle, cable, other. Just started the investigation, but figured I'd post here to see if anyone has experienced.

Symptom is a binding that requires more than normal foot pressure to get "a release". This occurs on initial 1st gear only, and only periodically. Does not occur on higher gears. For 1st, it might be from stop or after cruising down to first.

On car off, I've done the simple things like check pedal, butterfly opening by pulling the the cable, the interface at the cruise control diaphram, etc. No binding.

I'm thinking it might be related to the idle screw adjustment that I made, but think that is nothing more than a little/gap rather than another stop adjustment for the butterfly.

Will plan on cleaning the butterfly and throttle body, but figured I'd check here as well.

- GT/5SFE
- 330,000
- Original pedal, cable, throttle etc
- Cruise control
- Known issue with IAC (not closing completely, idle adjustment screw (not stop screw) turned down completely to correct for idle adjustment)

You could have some carbon/hardened oily residue buildup on the inside bore of the throttle body (inside of the butterfly valve) and/or around the perimeter of the butterfly valve, causing the butterfly valve to make contact with the throttle body and not close completely (which would mimic an IAC valve not closing completely), which could explain but of your issues.

Doing your cleaning could resolve both issues (hopefully).