Switch to full style
From Tune Ups to Oil Changes, maintenance related
Post a reply

Trouble with front wheel bearing, help

Sat Feb 20, 2021 7:27 pm

I'm in the process of replacing my front wheel bearings and I can't remove the bearing housing. I took of the clip and seals but does the housing pull out of the knuckle or do I just replace the parts with the ball bearings that came out?

Trying to upload a pic
Members don't see the above ad. Register now

Re: Trouble with front wheel bearing, help

Sat Feb 20, 2021 7:31 pm

Here's what I can't get out.
Does it just press out towards the rear? I tried to push it out with my hub grappler but stopped because I wasn't seeing it move
Attachments
20210220_122518_resize_76.jpg

Re: Trouble with front wheel bearing, help

Sat Feb 20, 2021 10:30 pm

Pretty normal stuff. Thats the bearing race... Did you already to the other side?

Best bet is to use new bearing to press old one out if you don't have another bearing to use.

Re: Trouble with front wheel bearing, help

Sun Feb 21, 2021 1:47 am

abeans wrote:Pretty normal stuff. Thats the bearing race... Did you already to the other side?

Best bet is to use new bearing to press old one out if you don't have another bearing to use.


Haven't take apart the other side yet. Don't they only fit on one side though? I'm talking about the bearing race housing that needs to get pushed out....Or are you talking about the ball bearing parts?
I did just buy the 20 ton shop press special from harbor freight though. I'll probably install the polyurethane bushings on my control arms since I'm in that area. Probably...... :P

Re: Trouble with front wheel bearing, help

Sun Feb 21, 2021 10:24 pm

Bearings are same on all 4 corners.

Re: Trouble with front wheel bearing, help

Mon Feb 22, 2021 1:46 am

abeans wrote:Bearings are same on all 4 corners.

Yeah I bought 4 of them.
Only problem I had was the seals I purchased for the rear of the hub assembly are good BUT the ones I purchased for the front (behind the studs) are the wrong ones so I had to re-use that one.
That and I started to press the hub back in without the dust shield back on :shoots: I just cut a entry to slide it back on.
Tomorrow I'll install this one back on and do it over again I am having fun
Post a reply