Page 2 of 2

Re: Fuel pump shuts off after a couple minutes

PostPosted: Tue Nov 15, 2022 6:42 pm
by alltracman78
underscore wrote:Some of them I can find descriptors for, but others I have no clue. The RC apparently has:
EVP - ??? *Evap electric VSV. USDM uses a bimetal VSV.*
ISCV - ??? *I don't have this on my RC pinouts.*
RLY - ??? *To the level sensor in the IC. Grounds while "full". This is the pin you ground if you're using a facelift engine harness with the RC ECU*
ECO - ??? *Economy button?*
ACT - ??? *To AC control. US has this also. Possibly engine RPM?*
ATS - ??? *To AC control. US has this also.*
CCO - ??? *IIRC This goes to the EGT probe after the cat*
WIN - Intercooler ECU
that the USDM doesn't have.

The USDM has:
HT - O2 heater
STJ - Cold Start Injector *JDM (including RC) has this also.*
that the RC doesn't have.

Answers are in bold.

underscore wrote:I tried, I can report back that with the probe stuck into the back of the plug with the COR installed it reads a bit of resistance and voltage to ground when running. That was annoying because I couldn't just leave the meter on short test and listen for the beep to stop as I drove around. If you switch the engine off and the key to ON it shows 12V as expected. The car did shut off once, but when I coasted to a safe spot to look at the meter and crank the engine it just fired up and ran normally the rest of the evening. :bangshead:

From what I understand, originally when it died it would stay dead for a while? If that's the case it seems like disturbing the FC wire makes a difference? You may have an issue there? Take a very close look at the wire.
I've had a code for the AFM signal because when they crimped the wire at the factory a TINY bit of insulation was under the crimp. Drove for years without a problem and then when I disturbed the harness and connector (was actually when I was playing around with combinations of the RC and US ECU and AFM) the fault popped up.

underscore wrote:That's another good thing for me to check, the inconsistency is killing me though. I much prefer when something breaks and stays broken so I can just find it and fix it lol.

This is the fun part! It's what separates the men from the boys, as they say. :P

If this makes you feel any better, here: ... ng%20Relay ... relay.html

Re: Fuel pump shuts off after a couple minutes

PostPosted: Tue Nov 15, 2022 9:18 pm
by underscore
Yes originally it would die and stay dead until I put the jumper in. The wires got a fair bit of jiggling and being moved to different orientations because when I swapped the ECU and COR I didn't fully install/uninstall them. It's a bit hard to get good eyes on it when it's all jammed under the dash but at least if I need to replace the FC wire it's not a long job lol.

Those diagrams are very helpful! It looks like Toyota used the same setup for multiple cars so I'll consider it safe to assume the 185 is the same. Though I'm not too sure what's going on with those ignition status signals coming into the ECU in the second one. Annoyingly the NE signal dropping out only triggers a code if the engine is above 1000 rpm, so if it's dropping out at idle and killing the engine I won't get a code for it.

More testing I suppose.

Re: Fuel pump shuts off after a couple minutes

PostPosted: Wed Nov 16, 2022 6:14 am
by Gert
Can't help you here. Most things are already spoken.
Other ECU = same problem.
So, nothing left then check if relays are receiving power and ground and broken or corroded wiring.
If all that is good and the "kill signall" is coming out off the ECU, I really have no idea how or when the Toyota ECU is programmed to do this.

Good luck.

Re: Fuel pump shuts off after a couple minutes

PostPosted: Mon Nov 21, 2022 3:25 am
by underscore
I put over 1000km on the car this weekend and it never shut off so I'm not sure what to do at this point. My best guess is something had corrosion on it after sitting for a couple years but now it's been cleaned off.

The alternator wasn't working on startup a couple of times, so I might have to dig into that now instead lol. It always came back if I shut the car off for a minute and then tried again though.