Arizona st185~0013191

New members MUST post a new intro thread before they can access the rest of the forum.

Arizona st185~0013191

Postby Kunnobrah » Wed May 15, 2019 8:44 pm

Hi , I’ve been coming to the site for years now and I’ve finally gotten around to making an account!
I have a white 1991 Toyota Celica all trac turbo, currently swapping the rc motor and transmission out with a 3rd gen 3sgte with lots of cherries on top! Paint will be done in 2 weeks as well!

Story time: I’ve always wanted an alltrac/gt4 since I was 12 seeing as my sisters boyfriend had a 91 gt and man i fell in love with it and soon found out that there was a performance version so I had to get my hands on one as soon as I could, fast forward to when I was 18 and at university of Arizona, I currently was on my 2nd 91 celica gt and I saw it for sale for 4K from a fellow alltrac member as well as an mr2 enthusiast. I quickly borrowed money from everyone I knew and took a plane ride out to El Paso Texas and test drove it for 1 minute and drove it home 8 hours non stop just for gas, the kicker was he took the radio and all I could hear was the engine and turbo spool the whole ride home. All the work that’s been done to it has been done myself since anything you need to do to it you lose an arm and a leg Paying someone else to do it. :offtopic: stock motor got toasted after putting a front mount and man it was baaad a lot of jimmies were rustled nd an inexperienced teenager rushing to get t back on the road let it die too soon. 2nd motor put in was a jdm a2a everything went smoothly now that I had actual tools I replaced every thing I could including suspension and polyurethane bushings everywhere, all I needed was to put the wheels and crossmember on and i was in the clear, left the car idling for a few minutes and everything was fine, went inside to shower and when I came back out steam was shooting out of everywhere, turns out the radiator had a tint hole that didn’t start leaking till the pressure went up and evaporated out of it, cylinder 3 piston rings were toast compression at 15. On to the next engine, was an mr2 3s and i swapped everything over to it, everything went smoothly again, this time I wanted to see if it would overheat, so I neutral revved it to about 6k rpm for a minute and eventually the car turned off, turned it back on and knock knock who’s there? Cylinder 3 crankshaft bearing went toast, replaced it and put a moroso pan at the same time, turned it on and no more knocking, at high revs I heard the very slightest wiggling / shifting kind of like a baby knock, compression was good everywhere so what could it be? I assume a wrist pin so I took it apart again and finally ordered the rc engine and transmission, slapped it all in with services done to it and that’s where she’s at now, drove it for 1.5k miles tops and everything’s fine with it but from the get go I’m 99% sure it has a burnt valve somewhere, vacuumed lumpy at times but since I run full e85 and up the idle from the screw you can hardly tell it’s got a lopy idle . Now I’m rust proofing it and painting the car and before I do so I might as well drop in one mean green bean and have it set.
Current mods to the car are, 3in turbo back exhaust(nocat, passes emissions flying by), k&n intake, turbosmart recirculating bov, dual stage boost controller(1st ~7 psi 2nd 17psi), act street disk, act hd pressure plate, lightweight flywheel, retarded exhaust cam 5.8 degrees, upgraded aluminum radiator, short shifter, 12k Swift springs on bc racing rs series coilovers, polyurethane bushings everywhere, 17” oz rally white wheels, that’s pretty much it I believe. If you’ve read this far thanks! Nice to meet everyone!
Members don't see the above ad. Register now - it's free!
Kunnobrah
Newbie
 
Posts: 4
Joined: Wed Apr 01, 2015 4:59 pm

Return to New Member Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron