Page 3 of 3

Re: My new All-Trac St185

PostPosted: Sun Nov 15, 2020 6:05 am
by alltrac801
Alright I think that's what I'll tackle next once I get my wiring figured out. Thanks a lot Corey!

Re: My new All-Trac St185

PostPosted: Wed Nov 18, 2020 9:00 pm
by alltrac801
Still trying to find my wiring issue but while I have the dash taken apart I was just looking over stuff and someone has definitely been under there before and messed with pretty much every wiring connecter and didn't know how to separate them without almost destroying the clips.

I figured I would check my ECU's and repair it if any capacitors were leaking but when I opened the ECU up the board looks like new! how could I tell if the ECU has been replaced? even the clear factory plastic (now yellow ish) was still on top of the ECU.

Re: My new All-Trac St185

PostPosted: Thu Nov 19, 2020 1:46 am
by underscore
They're sealed up pretty nicely, they should all look new in there unless something is seriously wrong.

Re: My new All-Trac St185

PostPosted: Thu Nov 19, 2020 1:51 am
by alltrac801
I just assumed where it's a 91 that maybe one capacitor would be a bad or going bad but like I said it looks brand new. But then again i have never looked inside of one before.

Re: My new All-Trac St185

PostPosted: Thu Nov 19, 2020 2:59 pm
by underscore
Ah I see what you mean. Capacitors can also dry out internally so they can look okay but still be causing problems. I think leaking as a failure is more common though

Re: My new All-Trac St185

PostPosted: Thu Nov 19, 2020 3:54 pm
by alltrac801
I didnt have a real reason to open up the ECU but i just figured I would check it out while i was under the dash and i was just really surprised that it looked in such good shape.