Aquamist HFS4-v3.1 Install, ST165

Q&A regarding engines, turbos, and intercoolers and power upgrades

Re: Aquamist HFS4-v3.1 Install, ST165

Postby underscore » Fri Aug 14, 2020 10:36 pm

Nice write up! I had a bung added to my intercooler but never ended up putting the system in, I assume it makes a big difference with the smaller 165 intercooler running that kind of pressure.
Members don't see the above ad. Register now - it's free!
★ 1991 GTFour RC ~ "Rebel Scum" ★
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 4552
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: Aquamist HFS4-v3.1 Install, ST165

Postby mickeyfinn » Fri Aug 14, 2020 10:53 pm

Thanks!
Heck Yeah! The whole reason is because of the ST165 Intercooler.
I really underestimated how poor the thing really is.
I don’t really want to bend and fabricate a bunch for a FMIC.
I have an ST205 Intercooler. No way it’s going without a bunch of cutting either.
I figured I’d give this a try.

Which Intercooler did you have that bung welded in?
I had a hard time finding any information on the Aquamist. So I figured I share what I know.
So many people have helped me here.
I hope it’s helpful to someone else.
mickeyfinn
Club Member
 
Posts: 94
Joined: Mon Sep 24, 2018 6:13 pm

Re: Aquamist HFS4-v3.1 Install, ST165

Postby underscore » Sat Aug 15, 2020 5:36 am

I had it welded into my stock RC WTA intercooler. I went for the same spot as you, as far away from the TB as I could get. Unfortunately the nozzle fouled on the timing belt snorkel and the 90* adapter I needed to make it work is discontinued so I put a plug in the bung and sold the kit.
★ 1991 GTFour RC ~ "Rebel Scum" ★
Build thread http://www.alltrac.net/phpBB2/viewtopic.php?f=44&t=44216
underscore
GTFour God
 
Posts: 4552
Images: 0
Joined: Mon Apr 09, 2007 11:29 pm
Location: Kelowna, BC

Re: Aquamist HFS4-v3.1 Install, ST165

Postby Gert » Fri Aug 21, 2020 6:00 am

Aquamist, good choice. I have an ERL System 2 kit in my car since 2001. Never had any (serious) malfunction issues.
Gert
Club Member
 
Posts: 67
Joined: Tue Sep 29, 2015 8:53 am

Re: Aquamist HFS4-v3.1 Install, ST165

Postby mickeyfinn » Mon Sep 14, 2020 8:17 pm

I've got everything wired up now... going through the pre-start checklist..

According to the manual:
Step 4.
Start the engine and let it idle for a minute or so:
- The green LED on the controller should flicker. The
flicker should speed up with engine speed. If the system
behaves as stated above, you have successfully
wired up the HFS-4!

I'm not seeing this. Somehow the Aquamist controller is not reading the Injector Duty Cycle.

The green wire (in the Aquamist RJ48 grey harness) is for sure connected to Fuel Injector #1 in the Car ECU harness.

I cut the wire, and reconnected them, just to make sure the green wire is indeed tapped into FI #1.
Not sure why it's not working.

I'm at a standstill until I get this resolved. I reached out to Aquamist to see if they have any ideas.
mickeyfinn
Club Member
 
Posts: 94
Joined: Mon Sep 24, 2018 6:13 pm

Previous

Return to Performance and Power

Who is online

Users browsing this forum: No registered users and 4 guests

cron