Switch to full style
Q&A regarding engines, turbos, and intercoolers and power upgrades
Post a reply

ST185 engine swap(ST205) no power on boost.

Tue May 20, 2014 5:12 pm

Hi,

I did engine swap on my st185. Mounted st205 engine +ECU. Everything seems to be working. I havent done vacuum and WTA radiator jet. Did a short trip around a block and car has no power... idle works good, idle power is good also, but in boost no real power comes. I see boost gage go quickly up (0,5bar) , but no power gain.

What would be most likely problem? Where to start?

1) air/fuel ratio?
2) Timing?
3) lambda sensor gone bad?
4) vacuum could do something?

I have no real good idea, but to but install wideband lambda sensor based air/fuel meter first.
Members don't see the above ad. Register now

Re: ST185 engine swap(ST205) no power on boost.

Wed May 21, 2014 1:59 am

check your coupler from intercooler to intake manifold and yeah could be vaccum as well, was it a front clip that you bought or just the engine? maybe a sensor is missing?

Re: ST185 engine swap(ST205) no power on boost.

Wed May 21, 2014 2:03 am

Factory gauge? Are you using the gen3 map?

Re: ST185 engine swap(ST205) no power on boost.

Wed May 21, 2014 3:50 am

it was only engine with wiring and ecu. aftermarket boost gauge. although factory boost gauge didnt show. ok i look vacuum and missing sensor. thanks.

Re: ST185 engine swap(ST205) no power on boost.

Thu May 22, 2014 2:57 pm

Ok I did quick check.

timing is right. 10 degrees and turns sooner higher rmp. So this can be left aside right now.

I found couple things:

mysterious connector:

What that can be?
Image


new motor has two lambda, one has only connected. The otherone is needed? : )

This one is connected:
Image

this one(lower) is not:
Image


If thats not it, I still belive, I have some sensor missing, maybe under the intake manifold. I didnt have that much time today.

Re: ST185 engine swap(ST205) no power on boost.

Fri May 23, 2014 3:08 pm

If you haven't wired in the intercoolerpump you will have the check engine light on and power is reduced.
The loose connector looks like the one for the boost solenoid, If it's blue? Hard to say from the picture.
That is an aftermarket downpipe that has an extra lambda bung. So the lower sensor is just used as a Plug. You could get a proper Plug for it. The thread size is m18x1,5

Re: ST185 engine swap(ST205) no power on boost.

Fri May 23, 2014 5:39 pm

thanks for replay ... second lambda can be left aside right now too. (Y)
-loose connector is black : )

I check some wiring (checking intercoolerpump wiring) and see what is below intake manifold (Vacuum and)... And I´II update my findings : )

Re: ST185 engine swap(ST205) no power on boost.

Fri May 23, 2014 6:23 pm

Yes, the second lambda has no function. They just used a lambda as plug.
I´m on my computer now and had a look at the picture and saw that is has 3 pins. That is for the speed sensor on the st205 transmission so that is not used on your car as it has a cable to the speedometer.

Re: ST185 engine swap(ST205) no power on boost.

Fri May 23, 2014 6:32 pm

Thanks, yes, that makes sense, one thing down in list again : ) ... (Y)

Re: ST185 engine swap(ST205) no power on boost.

Fri May 23, 2014 7:27 pm

The plug in the first pic looks similar to the WTA intercooler float plug. Is your float hooked up?

Re: ST185 engine swap(ST205) no power on boost.

Mon May 26, 2014 4:48 pm

Thanks guys, got it running. Sorted out diagnostic wires pins(w from ecu) and found code 41 (throttle position sensor). Moved around plug and its running now. Timing wasnt also in place thanks diagnostic wires. I have still work to do, but test drive was not so bad for old stock car : ). 0,6..7Bar and over 200kw for sure. Not 300kw understood, but still nice : ). Thanks again.

Re: ST185 engine swap(ST205) no power on boost.

Mon May 26, 2014 5:44 pm

The plug you are calling the 'second lambda' is not - it is a cat temp sensor. Leave it unplugged. In the ST205, it is only there to light a warning light on the dash.

-Charlie
Post a reply