Switch to full style
Talk EMS and Computer related performance
Post a reply

Gen 4 swap issues with MSD Tach Adapter?

Tue Jan 28, 2020 11:06 pm

I've been having issues with my gen 4 swapped ST165. The engine is pretty much stock besides a set of stock compression Wiesco pistons, rods and head studs. My harness was done by WireGap. For the longest time, I've had a wierd misfire/ignition breakup issue under load. Sometimes it was violent, like a boost-cut. I've done quite a bit to try to solve the issue. New plugs, coils, grounding, I re-pinned the connectors to the ECU, and many other things. Recently, I pulled the engine harness out to clean it up. Checked crimps and soldered connections to make sure all is well. I found some potential problem areas and addressed them. I put the harness back in and drove...the ignition still broke up and cut out. I was a bit pissed...Then on a whim, I decided to pull the ground off of my MSD Tach adapter and the car runs perfect!!! Pulls to redline at 16lbs of boost with great AFRs. I figured the tach adapter is the only thing in the ignition/timing system I have not messed with. I guess it was causing issues with the ECU.

Has anyone else seen weird issues like this? Does anyone know of a different solution to get my stock tach working?
Members don't see the above ad. Register now

Re: Gen 4 swap issues with MSD Tach Adapter?

Tue Jan 28, 2020 11:37 pm

Throw the MSD tach adapter in the trash and modify your current tach circuit... if you have the capabilities, that is. I did it on an old Alltrac Camry that I swapped a BEAMS motor in. It has coil-on-plug ignition, so had the same issue you are currently dealing with.

viewtopic.php?f=44&t=47129&start=45

Basically, you can increase the input sensitivity of the tach driver board.

Hope that helps.

-Charlie

Re: Gen 4 swap issues with MSD Tach Adapter?

Thu Jan 30, 2020 1:55 pm

Interesting! The MSD Tach adapter must be feeding back into the ECU. You could try and add a diode before the adapter to see if it helps. Sucks they don't have the QC or design knowledge to prevent these things from happening. Then again, the MSD adapter was designed with a SBC in mind not a 3SGTE!
Post a reply